summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLeon Arber <larber@ncsa.uiuc.edu>2006-03-07 04:23:24 (GMT)
committerLeon Arber <larber@ncsa.uiuc.edu>2006-03-07 04:23:24 (GMT)
commit840bcbe9ef762ae755df3f97fdac15d84df8909f (patch)
tree109540f2e45343bb529661b15962ece095ca7561 /configure.in
parent4efe32d5426f92083925d18183bc8669b58967b0 (diff)
downloadhdf5-840bcbe9ef762ae755df3f97fdac15d84df8909f.zip
hdf5-840bcbe9ef762ae755df3f97fdac15d84df8909f.tar.gz
hdf5-840bcbe9ef762ae755df3f97fdac15d84df8909f.tar.bz2
[svn-r12019] Purpose:
Bug fix/Feature Description: Modify the library to use rand_r, when available, instead of srand. If rand_r is not available, it will try to use srandom/random, and then finally fall back to srand/rand. Solution: A couple places in the library use the srand() function to seed the random number generator. This can cause problems on certain platforms and could theoretically cause problems for users who expect a certain sequence of random numbers following their own call to srand(). Most platforms have an implementation of rand_r, which is identical to rand, except that it allows for explicit storage of the seed value. The configure script will now check for the existence of rand_r to facilitate its use in the library. Two new functions are added, to replace the macros HDsrand/HDrand. These functions are HDrand and HDsrand. HDrand will call rand_r, if available, or random(), if available, and fall back to rand() if neither of those is available. HDsrand will store the seed value locally, if rand_r is available. Otherwise, it will call srandom if available, and fall back to srand otherwise. Platforms tested: heping, mir. Really need to test on Red Storm, since that platform motivated this fix, but the machine is currently not available. Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cb05076..ad81ff0 100644
--- a/configure.in
+++ b/configure.in
@@ -1606,7 +1606,7 @@ dnl
AC_CHECK_FUNCS(alarm fork frexpf frexpl gethostname getpwuid getrusage)
AC_CHECK_FUNCS(BSDgettimeofday longjmp setsysinfo sigaction)
AC_CHECK_FUNCS(signal snprintf vasprintf strdup system waitpid)
-AC_CHECK_FUNCS(random srandom)
+AC_CHECK_FUNCS(rand_r random srandom)
AC_CHECK_FUNCS(tmpfile)
dnl Check for vsnprintf() separately, so we can detect situations where it