summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2012-02-07 22:07:26 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2012-02-07 22:07:26 (GMT)
commit92d5cd3baf317573ed223d7fd373d8a8dc980547 (patch)
tree0c51c4961afc50431d3b5fc74a211f4d1d06a4c0 /configure.in
parentc614ba6fccbd3e665d2bd91c23e7f129e01b8f27 (diff)
downloadhdf5-92d5cd3baf317573ed223d7fd373d8a8dc980547.zip
hdf5-92d5cd3baf317573ed223d7fd373d8a8dc980547.tar.gz
hdf5-92d5cd3baf317573ed223d7fd373d8a8dc980547.tar.bz2
[svn-r21916] upper level commit :-\
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6d43501..8e2ca2f 100644
--- a/configure.in
+++ b/configure.in
@@ -3012,6 +3012,31 @@ if test "X$default_vfd" = "Xyes"; then
[Define the default virtual file driver to compile])
fi
+dnl --------------------------------------------------------------------------
+dnl Should the Default Virtual Object Layer plugin be compiled?
+dnl
+
+AC_MSG_CHECKING([for Default VOL definition])
+AC_ARG_WITH([default-vol],
+ [AC_HELP_STRING([--with-default-vol=plugin],
+ [Specify default vol plugin
+ [default=native]])],,
+ withval=native)
+
+if test "X$withval" = "Xnative"; then
+ AC_MSG_RESULT([yes])
+ default_vol=yes
+ vol_define=H5VL_NATIVE
+else
+ AC_MSG_RESULT([no])
+ default_vol=no
+fi
+
+if test "X$default_vol" = "Xyes"; then
+ AC_DEFINE_UNQUOTED([DEFAULT_VOL], [$vol_define],
+ [Define the default vol to compile])
+fi
+
dnl ----------------------------------------------------------------------
dnl Check if Direct I/O driver is enabled by --enable-direct-vfd
dnl