summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-04-12 21:28:09 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-04-12 21:28:09 (GMT)
commitb51ac70ed9baeabfc7fe5a0a31200b69b11f27cf (patch)
tree2d5576271807a0a1296da39ad5eb1fdf1d2a32fc /configure.in
parentbc66efc788bc77c9c133a9fc3cc29e26fa659bab (diff)
downloadhdf5-b51ac70ed9baeabfc7fe5a0a31200b69b11f27cf.zip
hdf5-b51ac70ed9baeabfc7fe5a0a31200b69b11f27cf.tar.gz
hdf5-b51ac70ed9baeabfc7fe5a0a31200b69b11f27cf.tar.bz2
[svn-r12230] Purpose:
Configuration change Description: Stream-VFD is now disabled when parallel is enabled. Solution: Stream-VFD was causing trouble on some platforms when both it and parallel HDF5 were being used. This is a pretty odd use case, so we now disable stream vfd when parallel is being used. This required moving the test for the stream vfd after the test for parallel HDF5 in configure.in. Platforms tested: mir, modi4 (configure change only)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in104
1 files changed, 61 insertions, 43 deletions
diff --git a/configure.in b/configure.in
index 35cbc1c..f14dbd9 100644
--- a/configure.in
+++ b/configure.in
@@ -1433,49 +1433,6 @@ else
fi
dnl ----------------------------------------------------------------------
-dnl Should the Stream Virtual File Driver be compiled in ?
-dnl
-AC_MSG_CHECKING([for Stream Virtual File Driver support])
-AC_ARG_ENABLE([stream-vfd],
- [AC_HELP_STRING([--enable-stream-vfd],
- [Build the Stream Virtual File Driver
- [default=yes]])],
- [STREAM_VFD=$enableval],
- [STREAM_VFD=yes])
-
-if test "$STREAM_VFD" = "yes"; then
- AC_MSG_RESULT([yes])
- AC_CHECK_HEADERS([netinet/in.h])
- AC_CHECK_HEADERS([netinet/tcp.h], , , [#include <netinet/in.h>])
- AC_CHECK_HEADERS([sys/filio.h])
- AC_DEFINE([HAVE_STREAM], [1],
- [Define if the stream virtual file driver should be compiled])
-
- dnl Check if 'socklen_t' available
- AC_MSG_CHECKING([if socklen_t is defined])
- AC_TRY_COMPILE([
-#include <stdio.h>
-#include <stdlib.h>
-#ifdef HAVE_UNISTD_H
-#include <unistd.h>
-#endif
-#ifdef HAVE_SYS_TYPES_H
-#include <sys/types.h>
-#endif
-#ifdef HAVE_SYS_SOCKET_H
-#include <sys/socket.h>
-#endif
- ],
- [socklen_t foo; return 0;],
- AC_DEFINE([HAVE_SOCKLEN_T], 1, [Define if `socklen_t' is defined])
- AC_MSG_RESULT([yes]),
- AC_MSG_RESULT([no])
- )
-else
- AC_MSG_RESULT([not configured])
-fi
-
-dnl ----------------------------------------------------------------------
dnl How does one figure out the local time zone? Anyone know of a
dnl Posix way to do this?
dnl
@@ -2518,6 +2475,67 @@ if test 1 = 2; then
fi
dnl ----------------------------------------------------------------------
+dnl Should the Stream Virtual File Driver be compiled in ?
+dnl
+AC_MSG_CHECKING([for Stream Virtual File Driver support])
+AC_ARG_ENABLE([stream-vfd],
+ [AC_HELP_STRING([--enable-stream-vfd],
+ [Build the Stream Virtual File Driver
+ [default=yes]])],
+ [STREAM_VFD=$enableval],
+ [STREAM_VFD=yes])
+
+dnl If the user explicitly disabled Stream VFD, say so.
+if test "$STREAM_VFD" != "yes"; then
+ AC_MSG_RESULT([not configured])
+fi
+
+dnl If the stream VFD is being used with parallel, disable it.
+dnl Using both stream VFD and parallel is a weird case and seems to cause errors on some
+dnl platforms.
+if test "$STREAM_VFD" = "yes" -a "X${enable_parallel}" = "Xyes"; then
+ AC_MSG_RESULT([not supported in parallel])
+ echo " warning! Stream-VFD is not supported in parallel"
+ STREAM_VFD=no
+fi
+if test "$STREAM_VFD" = "yes" -a "X${PARALLEL}" != "X"; then
+ AC_MSG_RESULT([not supported in parallel])
+ echo " warning! Stream-VFD is not supported when a parallel compiler is being used"
+ STREAM_VFD=no
+fi
+
+dnl Otherwise, use Stream VFD.
+if test "$STREAM_VFD" = "yes"; then
+ AC_MSG_RESULT([yes])
+ AC_CHECK_HEADERS([netinet/in.h])
+ AC_CHECK_HEADERS([netinet/tcp.h], , , [#include <netinet/in.h>])
+ AC_CHECK_HEADERS([sys/filio.h])
+ AC_DEFINE([HAVE_STREAM], [1],
+ [Define if the stream virtual file driver should be compiled])
+
+ dnl Check if 'socklen_t' available
+ AC_MSG_CHECKING([if socklen_t is defined])
+ AC_TRY_COMPILE([
+#include <stdio.h>
+#include <stdlib.h>
+#ifdef HAVE_UNISTD_H
+#include <unistd.h>
+#endif
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+ ],
+ [socklen_t foo; return 0;],
+ AC_DEFINE([HAVE_SOCKLEN_T], 1, [Define if `socklen_t' is defined])
+ AC_MSG_RESULT([yes]),
+ AC_MSG_RESULT([no])
+ )
+fi
+
+dnl ----------------------------------------------------------------------
dnl Decide whether the presence of user's exception handling functions is
dnl checked and data conversion exceptions are returned. This is mainly
dnl for the speed optimization of hard conversions. Soft conversions can