summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2007-06-29 20:52:56 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2007-06-29 20:52:56 (GMT)
commit1d7e8f9deedf6b2ce1cb6b7eea92236ed2f8dc28 (patch)
tree701e6acc390362121f10decfe692ed520f73f357 /configure.in
parent1091bb70297776d18a236e3efc55ac415a21c0f8 (diff)
downloadhdf5-1d7e8f9deedf6b2ce1cb6b7eea92236ed2f8dc28.zip
hdf5-1d7e8f9deedf6b2ce1cb6b7eea92236ed2f8dc28.tar.gz
hdf5-1d7e8f9deedf6b2ce1cb6b7eea92236ed2f8dc28.tar.bz2
[svn-r13928] Purpose: 1) Moving H5_CXX_HAVE_OFFSETOF macro to src/H5pubconf.h file.
2) Removing configuration of c++/src/H5cxx_pubconf.h file. Reasoning: the additional pubconf file caused compilation complications, this is cleaner. Tested: kagiso, smirom
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index a805593..0512054 100644
--- a/configure.in
+++ b/configure.in
@@ -444,22 +444,6 @@ int main(void) {
CXXFLAGS="${CXXFLAGS} -DBOOL_NOTDEFINED"
])
- AC_CONFIG_HEADER([c++/src/H5cxx_config.h])
-
- AC_OUTPUT_COMMANDS([
- echo "creating c++/src/H5cxx_pubconf.h"
- sed 's/#define /#define H5_CXX_/' <c++/src/H5cxx_config.h |\
- sed 's/#undef /#undef H5_CXX_/' >pubconf
- if test ! -f c++/src/H5cxx_pubconf.h; then
- /bin/mv -f pubconf c++/src/H5cxx_pubconf.h
- elif (diff pubconf c++/src/H5cxx_pubconf.h >/dev/null); then
- rm -f pubconf
- echo "c++/src/H5cxx_pubconf.h is unchanged"
- else
- /bin/mv -f pubconf c++/src/H5cxx_pubconf.h
- fi
- ])
-
AC_MSG_CHECKING([if $CXX has offsetof extension])
AC_TRY_COMPILE([
#include <stdio.h>
@@ -476,7 +460,7 @@ int main(void) {
x = offsetof(struct index_st, len);
y = offsetof(index_t, num)
],
- AC_DEFINE([HAVE_OFFSETOF], [1],
+ AC_DEFINE([CXX_HAVE_OFFSETOF], [1],
[Define if C++ compiler recognizes offsetof])
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no]))