summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-10 20:52:34 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-10 20:52:34 (GMT)
commit418968677b90fc7ed8a7f4293e9bd0e75a40b548 (patch)
tree1fdb927932e6f8f1709ed573c82b608a83f4f441 /configure.in
parentbdbf2b7909a4fd4585099063d78b2832a38d635b (diff)
downloadhdf5-418968677b90fc7ed8a7f4293e9bd0e75a40b548.zip
hdf5-418968677b90fc7ed8a7f4293e9bd0e75a40b548.tar.gz
hdf5-418968677b90fc7ed8a7f4293e9bd0e75a40b548.tar.bz2
[svn-r10179] Purpose:
Automake update cleanup and minor changes Description: Removed macros in acsite.m4 that are no longer used. Switched to using autoconf's AC_LANG_PUSH(Fortran) instead of old AC_LANG_FORTRAN9X macro. Switched to using AC_LANG_PUSH() and AC_LANG_POP() (from old AC_LANG_X). Added ifort to list of Fortran compilers configure will look for. Added a note about automake change to Release Notes. Platforms tested: copper, modi4 (parallel and serial), eirene
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 16 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 6ba1d00..94932fb 100644
--- a/configure.in
+++ b/configure.in
@@ -280,13 +280,18 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
dnl
FCFLAGS="${FCFLAGS} ${FFLAGS}"
+ dnl --------------------------------------------------------------------
+ dnl Fortran source extention
+ dnl
+ FC_SRCEXT=f90
+
AC_SUBST([F9XSUFFIXFLAG])
AC_SUBST([FSEARCH_DIRS])
dnl --------------------------------------------------------------------
dnl Check for a Fortran 9X compiler and how to include modules.
dnl
- AC_PROG_FC([f90 pgf90 slf90 f95 g95 xlf95 efc],)
+ AC_PROG_FC([f90 pgf90 slf90 f95 g95 xlf95 efc ifort],)
AC_F9X_MODS
dnl It seems that libtool (as of Libtool 1.5.14) is trying to
@@ -295,7 +300,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
F77=$FC
dnl Change to the Fortran 90 language
- AC_LANG_FORTRAN9X
+ AC_LANG_PUSH(Fortran)
dnl --------------------------------------------------------------------
dnl See if the compiler will support the "-I." option
@@ -311,8 +316,8 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_MSG_RESULT(no)
FCFLAGS="$FCFLAGS_saved")
- dnl Change to the C language
- AC_LANG_C
+ dnl Change back to the C language
+ AC_LANG_POP(Fortran)
else
echo "no"
fi
@@ -338,7 +343,7 @@ if test "X$HDF_CXX" = "Xyes"; then
HDF5_INTERFACES="$HDF5_INTERFACES c++"
dnl Change to the C++ language
- AC_LANG_CPLUSPLUS
+ AC_LANG_PUSH(C++)
AC_MSG_CHECKING([if $CXX needs old style header files in includes])
AC_TRY_RUN([
@@ -416,8 +421,8 @@ int main(void) {
CXXFLAGS="${CXXFLAGS} -DNO_STATIC_CAST"
])
- dnl Change to the C language
- AC_LANG_C
+ dnl Change back to the C language
+ AC_LANG_POP(C++)
else
echo "no"
fi
@@ -1992,7 +1997,7 @@ dnl `mpirun' from the same directory as mpif90 if it exists.
dnl
if test "X$HDF_FORTRAN" = "Xyes"; then
dnl Change to the Fortran 90 language
- AC_LANG_FORTRAN9X
+ AC_LANG_PUSH(Fortran)
case "$FC" in
*mpif90*)
@@ -2038,7 +2043,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
esac
dnl Change to the C language
- AC_LANG_C
+ AC_LANG_POP(Fortran)
fi
dnl ----------------------------------------------------------------------
@@ -2080,7 +2085,7 @@ case "X-$enable_parallel" in
if test "X$HDF_FORTRAN" = "Xyes"; then
dnl Change to the Fortran 90 language
- AC_LANG_FORTRAN9X
+ AC_LANG_PUSH(Fortran)
dnl Try link a simple MPI program. If fail, try again with -lmpi.
AC_TRY_FLINK(mpif.h, [
@@ -2104,7 +2109,7 @@ case "X-$enable_parallel" in
fi
dnl Change to the C language
- AC_LANG_C
+ AC_LANG_POP(Fortran)
fi
dnl Set RUNPARALLEL to mpirun if not set yet.