summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2007-07-12 22:01:35 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2007-07-12 22:01:35 (GMT)
commitb4e029c70b5d23cde5b58d23bf244eac3b1b9077 (patch)
tree78a5382d3b22543b70b1612249c04e5d0c37b1e5 /configure.in
parenta73ea1b4f06635fa712d93f3d956fbede0bd8294 (diff)
downloadhdf5-b4e029c70b5d23cde5b58d23bf244eac3b1b9077.zip
hdf5-b4e029c70b5d23cde5b58d23bf244eac3b1b9077.tar.gz
hdf5-b4e029c70b5d23cde5b58d23bf244eac3b1b9077.tar.bz2
[svn-r13971] Description:
Add --enable-deprecated-symbols configure option, to allow users to remove deprecated public API symbols at configure time. Add bin/make_vers script to bin/reconfigure actions. Run bin/reconfigure to regenerate autotool components. Tested on: Mac OS X/32 10.4.10 (amazon) FreeBSD/32 6.2 (duty) Linux/32 2.6 (kagiso)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 28 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0512054..2f8bf37 100644
--- a/configure.in
+++ b/configure.in
@@ -95,7 +95,7 @@ dnl
DEFAULT_LIBS=""
dnl Support F9X variable to define Fortran compiler if FC variable is
-dnl not used. This should be depreciated in the future.
+dnl not used. This should be deprecated in the future.
if test "x" = "x$FC"; then
FC=${F9X}
fi
@@ -3679,6 +3679,30 @@ fi
AM_CONDITIONAL([BUILD_ALL_CONDITIONAL], [test "X$BUILD_ALL" = "Xyes"])
dnl ----------------------------------------------------------------------
+dnl Enable deprecated public API symbols
+dnl
+AC_SUBST([DEPRECATED_SYMBOLS])
+AC_MSG_CHECKING([if deprecated public symbols are available]);
+AC_ARG_ENABLE([deprecated-symbols],
+ [AC_HELP_STRING([--enable-deprecated-symbols],
+ [Enable deprecated public API symbols [default=yes]])],
+ [DEPREC_SYMBOLS=$enableval],
+ [DEPREC_SYMBOLS=yes])
+
+case "X-$DEPREC_SYMBOLS" in
+ X-yes)
+ AC_MSG_RESULT([yes])
+ DEPRECATED_SYMBOLS=yes
+ ;;
+ X-no|*)
+ AC_MSG_RESULT([no])
+ DEPRECATED_SYMBOLS=no
+ AC_DEFINE([NO_DEPRECATED_SYMBOLS], [1],
+ [Define if deprecated public API symbols are disabled])
+ ;;
+esac
+
+dnl ----------------------------------------------------------------------
dnl Create automake conditionals to tell automake makefiles which directories
dnl need to be compiled
@@ -3926,6 +3950,9 @@ IF_YES_NO "$enable_static"
PRINT_N " Statically Linked Executables"
IF_YES_NO "$STATIC_EXEC"
+PRINT_N " With Deprecated Public Symbols"
+IF_YES_NO "$DEPRECATED_SYMBOLS"
+
PRINT_N " Tracing"
IF_YES_NO "$TRACE_API"