summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2007-11-20 03:43:58 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2007-11-20 03:43:58 (GMT)
commitb4f4670c811cae49e08f1799b6ea69a8bb1345f3 (patch)
tree5bcfdbd9e8dd0e86ee816d33da7739e752edcf34 /configure.in
parentf23b5aafc1878b0dd4aac27184500c19cf0b8edd (diff)
downloadhdf5-b4f4670c811cae49e08f1799b6ea69a8bb1345f3.zip
hdf5-b4f4670c811cae49e08f1799b6ea69a8bb1345f3.tar.gz
hdf5-b4f4670c811cae49e08f1799b6ea69a8bb1345f3.tar.bz2
[svn-r14270] Description:
Removed the stream-vfd from the basic library code. (The stream-vfd source files are not removed yet but the MANIFEST has been updated to NOT release those stream-vfd source files.) Platforms tested: Kagiso and smirom. Then test the release tar ball in kagiso.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in70
1 files changed, 0 insertions, 70 deletions
diff --git a/configure.in b/configure.in
index 51df00c..8aae78b 100644
--- a/configure.in
+++ b/configure.in
@@ -2688,73 +2688,6 @@ if test "X$default_vfd" = "Xyes"; then
[Define the default virtual file driver to compile])
fi
-dnl -----------------------------------------------------------------------------
-dnl Should the Stream Virtual File Driver be compiled in ?
-dnl
-AC_MSG_CHECKING([for Stream Virtual File Driver support])
-AC_ARG_ENABLE([stream-vfd],
- [AC_HELP_STRING([--enable-stream-vfd],
- [Build the Stream Virtual File Driver
- [default=yes]])],
- [STREAM_VFD=$enableval],
- [STREAM_VFD=default])
-
-dnl If the user explicitly disabled Stream VFD, say so.
-if test "$STREAM_VFD" != "yes" -a "$STREAM_VFD" != "default"; then
- AC_MSG_RESULT([not configured])
-fi
-
-dnl If stream VFD is being used with parallel, disable it, unless the user
-dnl explicity enables it via the '--enable-stream_vfd' option.
-if test "$STREAM_VFD" = "default" -a "X${enable_parallel}" = "Xyes"; then
- AC_MSG_RESULT([disabled in parallel])
- STREAM_VFD=no
-elif test "$STREAM_VFD" = "yes" -a "X${enable_parallel}" = "Xyes"; then
- AC_MSG_RESULT([enabled by user])
-elif test "$STREAM_VFD" = "default" -a "X${PARALLEL}" != "X"; then
- AC_MSG_RESULT([disabled when a parallel compiler is being used])
- STREAM_VFD=no
-elif test "$STREAM_VFD" = "yes" -a "X${PARALLEL}" != "X"; then
- AC_MSG_RESULT([enabled by user])
-elif test "$STREAM_VFD" = "yes"; then
- AC_MSG_RESULT([yes])
-fi
-
-if test "$STREAM_VFD" = "default"; then
- AC_MSG_RESULT([yes])
- STREAM_VFD=yes
-fi
-
-dnl Otherwise, use Stream VFD.
-if test "$STREAM_VFD" = "yes"; then
- AC_CHECK_HEADERS([netinet/in.h])
- AC_CHECK_HEADERS([netinet/tcp.h], , , [#include <netinet/in.h>])
- AC_CHECK_HEADERS([sys/filio.h])
- AC_DEFINE([HAVE_STREAM], [1],
- [Define if the stream virtual file driver should be compiled])
-
- dnl Check if 'socklen_t' available
- AC_MSG_CHECKING([if socklen_t is defined])
- AC_TRY_COMPILE([
-#include <stdio.h>
-#include <stdlib.h>
-#ifdef HAVE_UNISTD_H
-#include <unistd.h>
-#endif
-#ifdef HAVE_SYS_TYPES_H
-#include <sys/types.h>
-#endif
-#ifdef HAVE_SYS_SOCKET_H
-#include <sys/socket.h>
-#endif
- ],
- [socklen_t foo; return 0;],
- AC_DEFINE([HAVE_SOCKLEN_T], 1, [Define if `socklen_t' is defined])
- AC_MSG_RESULT([yes]),
- AC_MSG_RESULT([no])
- )
-fi
-
dnl ----------------------------------------------------------------------
dnl Check if Direct I/O driver is enabled by --enable-direct-vfd
dnl
@@ -4049,9 +3982,6 @@ else
fi
-PRINT_N " Stream VFD"
-IF_ENABLED_DISABLED "$STREAM_VFD"
-
PRINT_N " Direct VFD"
IF_ENABLED_DISABLED "$DIRECT_VFD"