summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-04-22 23:44:41 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-04-22 23:44:41 (GMT)
commit0c7f15227c652ebb5036ef55da56437c9b14129c (patch)
treefc0b7162dde9ff6ccb75005f9ad0c9afa2d36bd6 /configure.in
parent7b022bbfb8b8780cd82d0f8aeed0f18e95276ed0 (diff)
downloadhdf5-0c7f15227c652ebb5036ef55da56437c9b14129c.zip
hdf5-0c7f15227c652ebb5036ef55da56437c9b14129c.tar.gz
hdf5-0c7f15227c652ebb5036ef55da56437c9b14129c.tar.bz2
[svn-r5225] Purpose:
Feature Fix Description: Modified the AC_OUTPUT macro to coincide with the now-standard way of doing things. I.e., you put all of the files you want to generate into the AC_CONFIG_FILES macro and invode AC_OUTPUT with no parameters. Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in106
1 files changed, 58 insertions, 48 deletions
diff --git a/configure.in b/configure.in
index d424192..d30e9b7 100644
--- a/configure.in
+++ b/configure.in
@@ -117,16 +117,16 @@ esac
host_config="none"
for f in $host_cpu-$host_vendor-$host_os \
- $host_cpu-$host_vendor-$host_os_novers \
- $host_vendor-$host_os \
+ $host_cpu-$host_vendor-$host_os_novers \
+ $host_vendor-$host_os \
$host_vendor-$host_os_novers \
- $host_cpu-$host_os \
+ $host_cpu-$host_os \
$host_cpu-$host_os_novers \
$host_cpu-$host_vendor \
- $host_os \
- $host_os_novers \
- $host_vendor \
- $host_cpu ; do
+ $host_os \
+ $host_os_novers \
+ $host_vendor \
+ $host_cpu ; do
AC_MSG_CHECKING(for config $f)
if test -f "$srcdir/config/$f"; then
host_config=$srcdir/config/$f
@@ -260,7 +260,7 @@ esac
AC_MSG_CHECKING(make)
AC_SUBST_FILE(DEPEND)
if test "`${MAKE-make} --version -f /dev/null 2>/dev/null |\
- sed -n 1p|cut -c1-8`" = "GNU Make"; then
+ sed -n 1p|cut -c1-8`" = "GNU Make"; then
AC_MSG_RESULT(GNU make)
GMAKE=yes
if test "X$GCC" = "Xyes"; then
@@ -583,12 +583,12 @@ AC_TRY_COMPILE([
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
#endif
- ],
- [dev_t d1, d2; if(d1==d2) return 0;],
- AC_DEFINE(DEV_T_IS_SCALAR, 1,
- [Define if \`dev_t' is a scalar])
- AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no)
+ ],
+ [dev_t d1, d2; if(d1==d2) return 0;],
+ AC_DEFINE(DEV_T_IS_SCALAR, 1,
+ [Define if \`dev_t' is a scalar])
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
)
dnl ----------------------------------------------------------------------
@@ -622,6 +622,10 @@ case $withval in
HAVE_ZLIB="yes"
AC_CHECK_HEADERS(zlib.h)
AC_CHECK_LIB(z, compress2,, unset HAVE_ZLIB)
+
+ if test -z "$HAVE_ZLIB" -a -n "$HDF5_CONFIG_ABORT"; then
+ AC_MSG_ERROR(couldn't find zlib library)
+ fi
;;
no)
HAVE_ZLIB="no"
@@ -657,6 +661,10 @@ case $withval in
fi
AC_CHECK_LIB(z, compress2,, LDFLAGS="$saved_LDFLAGS"; unset HAVE_ZLIB)
+
+ if test -z "$HAVE_ZLIB" -a -n "$HDF5_CONFIG_ABORT"; then
+ AC_MSG_ERROR(couldn't find zlib library)
+ fi
;;
esac
@@ -1750,40 +1758,42 @@ if test "$HAVE_PABLO" = "yes"; then
fi
fi
-AC_OUTPUT(src/libhdf5.settings
- config/depend1
- config/depend2
- config/depend3
- config/depend4
- config/dependN
- config/commence
- config/conclude
- Makefile
- src/Makefile
- $PABLO_MAKE
- test/Makefile
- $PARALLEL_MAKE
- perform/Makefile
- tools/Makefile
- tools/h5dump/Makefile
- tools/h5ls/Makefile
- tools/lib/Makefile
- tools/misc/Makefile
- tools/misc/h5cc
- tools/gifconv/Makefile
- examples/Makefile
- doc/Makefile
- doc/html/Makefile
- doc/html/ADGuide/Makefile
- doc/html/Graphics/Makefile
- doc/html/Intro/Makefile
- doc/html/PSandPDF/Makefile
- doc/html/TechNotes/Makefile
- doc/html/Tutor/Makefile
- doc/html/Tutor/Graphics/Makefile
- doc/html/Tutor/examples/Makefile
- doc/html/cpplus/Makefile
- doc/html/fortran/Makefile)
+AC_CONFIG_FILES([src/libhdf5.settings
+ config/depend1
+ config/depend2
+ config/depend3
+ config/depend4
+ config/dependN
+ config/commence
+ config/conclude
+ Makefile
+ src/Makefile
+ $PABLO_MAKE
+ test/Makefile
+ $PARALLEL_MAKE
+ perform/Makefile
+ tools/Makefile
+ tools/h5dump/Makefile
+ tools/h5ls/Makefile
+ tools/lib/Makefile
+ tools/misc/Makefile
+ tools/misc/h5cc
+ tools/gifconv/Makefile
+ examples/Makefile
+ doc/Makefile
+ doc/html/Makefile
+ doc/html/ADGuide/Makefile
+ doc/html/Graphics/Makefile
+ doc/html/Intro/Makefile
+ doc/html/PSandPDF/Makefile
+ doc/html/TechNotes/Makefile
+ doc/html/Tutor/Makefile
+ doc/html/Tutor/Graphics/Makefile
+ doc/html/Tutor/examples/Makefile
+ doc/html/cpplus/Makefile
+ doc/html/fortran/Makefile])
+
+AC_OUTPUT
no_create=$saved_no_create
# Then the stamp2 file for H5config.h