summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2007-04-04 19:59:00 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2007-04-04 19:59:00 (GMT)
commit3431f74c438b25e7aeba9062ed1e948899457b46 (patch)
treeed7a1aa1282e74a0a4646762ce82f29b1749dbec /configure.in
parentea63d5fb19e8b260178e6f76e8ed0504ded148a3 (diff)
downloadhdf5-3431f74c438b25e7aeba9062ed1e948899457b46.zip
hdf5-3431f74c438b25e7aeba9062ed1e948899457b46.tar.gz
hdf5-3431f74c438b25e7aeba9062ed1e948899457b46.tar.bz2
[svn-r13588] A support of files bigger than 2GB for STDIO driver. Configure will
check if fseeko is available. Using it instead of fseek can support big files because the offset is of type off_t not long int. Also added the test for STDIO in big.c.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index dc9efc2..10900c7 100644
--- a/configure.in
+++ b/configure.in
@@ -1172,8 +1172,8 @@ esac
AC_TRY_COMPILE([#include <sys/types.h>],
[off64_t n = 0;],
- [AC_CHECK_FUNCS([lseek64 fseek64])],
- [AC_MSG_RESULT([skipping test for lseek64() and fseek64()])])
+ [AC_CHECK_FUNCS([lseek64 fseek64 fseeko ftello])],
+ [AC_MSG_RESULT([skipping test for lseek64(), fseek64(), fseeko(), and ftello])])
AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/stat.h>],