summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-09-17 22:47:02 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-09-17 22:47:02 (GMT)
commit5921ab6be1f8f96109587d4ea799f931e8372fca (patch)
tree48a785b7e0b9197d5901d4fd6f0bb4132a3e8a0a /configure.in
parentc54fa7409fe2a3c412d6e2d87c0b1a17de21f142 (diff)
downloadhdf5-5921ab6be1f8f96109587d4ea799f931e8372fca.zip
hdf5-5921ab6be1f8f96109587d4ea799f931e8372fca.tar.gz
hdf5-5921ab6be1f8f96109587d4ea799f931e8372fca.tar.bz2
[svn-r4448]
Purpose: New Feature Description: Added final output for the configure script which shows a summary of options people chose while configuring. Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in314
1 files changed, 240 insertions, 74 deletions
diff --git a/configure.in b/configure.in
index 97f5ebb..da60d43 100644
--- a/configure.in
+++ b/configure.in
@@ -607,6 +607,9 @@ dnl If HDF4 components are checked first and the libz is not found, it will
dnl cause the later checking of ZLIB componenets to fail too. But in this
dnl case, one can configure again without the optional with-hdf4 option.
dnl
+AC_SUBST(HAVE_HDF4) HAVE_HDF4="no"
+AC_SUBST(HAVE_ZLIB) HAVE_ZLIB="no"
+
AC_SUBST(H5TOH4) H5TOH4=h5toh4
AC_SUBST(TESTH5TOH4) TESTH5TOH4='$(srcdir)/testh5toh4.sh'
@@ -626,6 +629,7 @@ case "$withval" in
failed="no"
AC_CHECK_LIB(z, compress,, failed="yes")
if test "$failed" = "no"; then
+ HAVE_ZLIB="yes"
AC_CHECK_LIB(jpeg, jpeg_start_compress,, failed="yes")
fi
if test "$failed" = "no"; then
@@ -637,6 +641,8 @@ case "$withval" in
if test "$failed" = "yes"; then
unset H5TOH4 TESTH5TOH4 H4TOH5 H4TOH5TEST TESTH4TOH5
+ else
+ HAVE_HDF4="yes"
fi
;;
no)
@@ -676,6 +682,7 @@ case "$withval" in
fi
if test "$failed" = "no"; then
AC_CHECK_LIB(jpeg, jpeg_start_compress,, failed="yes")
+ HAVE_ZLIB="yes"
fi
if test "$failed" = "no"; then
AC_CHECK_LIB(df, Hstartaccess,, failed="yes")
@@ -688,6 +695,8 @@ case "$withval" in
CPPFLAGS="$saved_CPPFLAGS"
LDFLAGS="$saved_LDFLAGS"
unset H5TOH4 TESTH5TOH4 H4TOH5 H4TOH5TEST TESTH4TOH5
+ else
+ HAVE_HDF4="yes"
fi
;;
esac
@@ -709,7 +718,7 @@ AC_ARG_WITH(zlib,
case $withval in
yes)
AC_CHECK_HEADERS(zlib.h)
- AC_CHECK_LIB(z, compress)
+ AC_CHECK_LIB(z, compress, HAVE_ZLIB="yes",)
;;
no)
AC_MSG_CHECKING(for GNU zlib)
@@ -736,15 +745,13 @@ case $withval in
CPPFLAGS="$CPPFLAGS -I$zlib_inc"
fi
- AC_CHECK_HEADERS(zlib.h,,
- CPPFLAGS="$saved_CPPFLAGS")
+ AC_CHECK_HEADERS(zlib.h,, CPPFLAGS="$saved_CPPFLAGS")
if test -n "$zlib_lib"; then
LDFLAGS="$LDFLAGS -L$zlib_lib"
fi
- AC_CHECK_LIB(z, compress,,
- LDFLAGS="$saved_LDFLAGS")
+ AC_CHECK_LIB(z, compress, HAVE_ZLIB="yes", LDFLAGS="$saved_LDFLAGS")
;;
esac
@@ -771,11 +778,13 @@ case "$withval" in
AC_CHECK_LIB(globus_gass_transfer,main,,unset GASS TESTGASS)
AC_CHECK_LIB(globus_gass_file,globus_gass_open,,unset GASS TESTGASS)
;;
+
no)
AC_MSG_CHECKING(for GASS)
AC_MSG_RESULT(suppressed)
unset GASS TESTGASS
;;
+
*)
gass_inc="`echo $withval |cut -f1 -d,`"
@@ -967,8 +976,8 @@ dnl
AC_SUBST(PTHREAD) PTHREAD=yes
AC_ARG_WITH(pthread,
- [ --with-pthread=INC,LIB Use the Pthreads library],
- ,withval=no)
+ [ --with-pthread=INC,LIB Use the Pthreads library],,
+ withval=no)
case "$withval" in
yes)
@@ -1017,26 +1026,26 @@ AC_ARG_ENABLE(threadsafe,
THREADSAFE=$enableval)
case "X-$THREADSAFE" in
- X-|X-no)
- AC_MSG_RESULT(no)
- ;;
- X-yes)
- if test -n "$PTHREAD"; then
- AC_MSG_RESULT(yes)
- THREADSAFE=yes
- else
- AC_MSG_RESULT(error)
- AC_MSG_ERROR(needed pthread library not available)
- fi
- ;;
- *)
+ X-|X-no)
+ AC_MSG_RESULT(no)
+ ;;
+ X-yes)
+ if test -n "$PTHREAD"; then
+ AC_MSG_RESULT(yes)
+ THREADSAFE=yes
+ else
AC_MSG_RESULT(error)
- AC_MSG_ERROR(\'$enableval\' is not a valid threadsafe type)
- ;;
+ AC_MSG_ERROR(needed pthread library not available)
+ fi
+ ;;
+ *)
+ AC_MSG_RESULT(error)
+ AC_MSG_ERROR(\'$enableval\' is not a valid threadsafe type)
+ ;;
esac
if test "X$THREADSAFE" = "Xyes"; then
- AC_DEFINE(HAVE_THREADSAFE)
+ AC_DEFINE(HAVE_THREADSAFE)
fi
dnl ----------------------------------------------------------------------
@@ -1045,14 +1054,14 @@ dnl compiled in
dnl
AC_MSG_CHECKING(whether HDF5 v1.4 compatibility functions enabled)
AC_ARG_ENABLE(hdf5v1_4,
- [ --enable-hdf5v1_4 Compile the HDF5 v1.4 compatibility interface [default=no]],
- HDF5_V1_4_COMPAT=$enableval)
+ [ --enable-hdf5v1_4 Compile the HDF5 v1.4 compatibility interface [default=no]],
+ HDF5_V1_4_COMPAT=$enableval)
-if test "X$HDF5_V1_4_COMPAT" = "Xyes"; then
- AC_MSG_RESULT(yes)
- AC_DEFINE(WANT_H5_V1_4_COMPAT)
+if test "$HDF5_V1_4_COMPAT" = "yes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WANT_H5_V1_4_COMPAT)
else
- AC_MSG_RESULT(no)
+ AC_MSG_RESULT(no)
fi
dnl ----------------------------------------------------------------------
@@ -1060,17 +1069,17 @@ dnl Should the Stream Virtual File Driver be compiled in ?
dnl
AC_MSG_CHECKING(for Stream Virtual File Driver support)
AC_ARG_ENABLE(stream-vfd,
- [ --enable-stream-vfd Build the Stream Virtual File Driver. [default=no]],
- STREAM_VFD=$enableval)
+ [ --enable-stream-vfd Build the Stream Virtual File Driver. [default=no]],
+ STREAM_VFD=$enableval)
-if test "X$STREAM_VFD" = "Xyes"; then
- AC_MSG_RESULT(yes)
- AC_CHECK_HEADERS(netinet/tcp.h sys/filio.h)
- AC_DEFINE(HAVE_STREAM)
+if test "$STREAM_VFD" = "yes"; then
+ AC_MSG_RESULT(yes)
+ AC_CHECK_HEADERS(netinet/tcp.h sys/filio.h)
+ AC_DEFINE(HAVE_STREAM)
- dnl Check if 'socklen_t' available
- AC_MSG_CHECKING([if socklen_t is defined])
- AC_TRY_COMPILE([
+ dnl Check if 'socklen_t' available
+ AC_MSG_CHECKING([if socklen_t is defined])
+ AC_TRY_COMPILE([
#include <stdio.h>
#include <stdlib.h>
#ifdef HAVE_UNISTD_H
@@ -1082,13 +1091,13 @@ if test "X$STREAM_VFD" = "Xyes"; then
#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>
#endif
- ],
- [socklen_t foo; return 0;],
- AC_DEFINE(HAVE_SOCKLEN_T) AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no)
- )
+ ],
+ [socklen_t foo; return 0;],
+ AC_DEFINE(HAVE_SOCKLEN_T) AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+ )
else
- AC_MSG_RESULT(not configured)
+ AC_MSG_RESULT(not configured)
fi
dnl ----------------------------------------------------------------------
@@ -1237,39 +1246,39 @@ dnl Turn on debugging by setting compiler flags
dnl
AC_MSG_CHECKING(for debug flags)
AC_ARG_ENABLE(debug,
- [ --enable-debug[=all] Turn on debugging in all packages. One may also
+ [ --enable-debug[=all] Turn on debugging in all packages. One may also
specify a comma-separated list of package names
without the leading H5 or the word no. The default
is most packages.],
- DEBUG_PKG=$enableval)
+ DEBUG_PKG=$enableval)
AC_SUBST(DEBUG_PKG)
all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
- X-|X-yes)
- DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
- CPPFLAGS="$CPPFLAGS -UNDEBUG"
- AC_MSG_RESULT(default ($DEBUG_PKG))
- ;;
- X-all)
- DEBUG_PKG=$all_packages
- CPPFLAGS="$CPPFLAGS -UNDEBUG"
- AC_MSG_RESULT(all ($DEBUG_PKG))
- ;;
- X-no|X-none)
- AC_MSG_RESULT(none)
- DEBUG_PKG=
- CPPFLAGS="$CPPFLAGS -DNDEBUG"
- ;;
- *)
- AC_MSG_RESULT($DEBUG_PKG)
- ;;
+ X-|X-yes)
+ DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
+ CPPFLAGS="$CPPFLAGS -UNDEBUG"
+ AC_MSG_RESULT(default ($DEBUG_PKG))
+ ;;
+ X-all)
+ DEBUG_PKG=$all_packages
+ CPPFLAGS="$CPPFLAGS -UNDEBUG"
+ AC_MSG_RESULT(all ($DEBUG_PKG))
+ ;;
+ X-no|X-none)
+ AC_MSG_RESULT(none)
+ DEBUG_PKG=
+ CPPFLAGS="$CPPFLAGS -DNDEBUG"
+ ;;
+ *)
+ AC_MSG_RESULT($DEBUG_PKG)
+ ;;
esac
if test -n "$DEBUG_PKG"; then
- for pkg in `echo $DEBUG_PKG | tr 'a-z,' 'A-Z '`; do
- CPPFLAGS="$CPPFLAGS -DH5${pkg}_DEBUG"
- done
+ for pkg in `echo $DEBUG_PKG | tr 'a-z,' 'A-Z '`; do
+ CPPFLAGS="$CPPFLAGS -DH5${pkg}_DEBUG"
+ done
fi
dnl ----------------------------------------------------------------------
@@ -1282,13 +1291,13 @@ AC_ARG_ENABLE(trace,
AC_SUBST(TRACE_API)
if test -z "$TRACE" -o "X$TRACE" = "Xyes"; then
- AC_MSG_RESULT(yes)
- TRACE_API=yes
- CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
+ AC_MSG_RESULT(yes)
+ TRACE_API=yes
+ CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
else
- AC_MSG_RESULT(no)
- TRACE_API=no
- CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
+ AC_MSG_RESULT(no)
+ TRACE_API=no
+ CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
fi
dnl Checkpoint the cache
@@ -1752,7 +1761,7 @@ AC_OUTPUT(src/libhdf5.settings
pablo/Makefile
test/Makefile
$PARALLEL_MAKE
- perform/Makefile
+ perform/Makefile
tools/Makefile
tools/h5dump/Makefile
tools/h5ls/Makefile
@@ -1793,3 +1802,160 @@ cat >> src/H5config.h <<EOF
#endif
EOF
+PRINT() {
+ SPACES=" "
+ msg="$SPACES $1: "
+ msg_len="`echo \"$msg\" | wc -c | sed -e 's/ //g'`"
+ let "begin_msg=$msg_len-33"
+ echo "$msg" | cut -c$begin_msg- | tr -d '\012'
+}
+
+echo ""
+echo "Configuation Options:"
+
+PRINT "Compilation Mode"
+case "X-$enable_production" in
+ X-yes) echo "Production" ;;
+ X-|X-no) echo "Development" ;;
+ X-pg|X-profile) echo "Profile" ;;
+ *) echo "$enable_production" ;;
+esac
+
+PRINT "Debug Mode"
+case "X-$DEBUG_PKG" in
+ X-|X-yes) echo "Default" ;;
+ X-all) echo "All" ;;
+ X-no|X-none) echo "None" ;;
+ *) echo "$DEBUG_PKG" ;;
+esac
+
+PRINT "hsize_t"
+case "$HSIZET" in
+ no|small) echo "Small" ;;
+ *) echo "Large" ;;
+esac
+
+PRINT "HDF5 v1.4 Compatibility"
+if test "$HDF5_V1_4_COMPAT" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Linux LFS"
+if test "$LINUX_LFS" = "yes"; then
+ echo "Enabled"
+else
+ echo "Disabled"
+fi
+
+PRINT "Parallel HDF5"
+if test "$PARALLEL" != "no"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Shared Libraries"
+if test "$enable_shared" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Static Libraries"
+if test "$enable_static" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Statically Linked Executables"
+if test "$STATIC_EXEC" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Stream VFD"
+if test "$STREAM_VFD" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Tracing"
+if test -z "$TRACE" -o "X$TRACE" = "Xyes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Threadsafety"
+if test "$THREADSAFE" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+echo ""
+echo "Library Wrappers:"
+
+PRINT "Fortran"
+if test "$HDF_FORTRAN" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "C++"
+if test "$HDF_CXX" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+echo ""
+echo "Libraries/Modules:"
+
+PRINT "HDF4"
+if test "$HAVE_HDF4" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "GASS"
+if test "$GASS" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "GridStorage"
+if test -n "$GRIDSTORAGE"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "PThreads"
+if test -n "$PTHREAD"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "SRB"
+if test -n "$SRB"; then
+ echo "Yes"
+else
+ echo "No"
+fi
+
+PRINT "Zlib"
+if test "$HAVE_ZLIB" = "yes"; then
+ echo "Yes"
+else
+ echo "No"
+fi