summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2007-01-12 19:32:34 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2007-01-12 19:32:34 (GMT)
commit7072d7103d9ec03c4f1d1217cc45e966d867edbc (patch)
treea5a36b8732ce923a190751e336e2ba7cfe590b09 /configure.in
parent66cd68e65b66a9392aafb4e4e1ba4f14bee1b523 (diff)
downloadhdf5-7072d7103d9ec03c4f1d1217cc45e966d867edbc.zip
hdf5-7072d7103d9ec03c4f1d1217cc45e966d867edbc.tar.gz
hdf5-7072d7103d9ec03c4f1d1217cc45e966d867edbc.tar.bz2
[svn-r13138] Description:
Auto-detect the support for the posix_memalign routine and disable the direct I/O VFD if posix_memalign is not supported. This should allow direct I/O to be auto-detected and disabled on FreeBSD. (Direct I/O itself works fine, but doesn't have the alignment requirements on FreeBSD that it has on Linux, so the code would have to be re-worked to not use posix_memalign and we don't need to support that right now). Tested on: FreeBSD/32 6.1 (duty) Linux/32 2.4 (kagiso)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d24dabc..66c0a72 100644
--- a/configure.in
+++ b/configure.in
@@ -2607,7 +2607,7 @@ if test "$DIRECT_VFD" = "yes"; then
close(fid);
remove("tst_file");
exit (0);
- }], [hdf5_direct_io=yes], [hdf5_direct_io=no],)])
+ }], AC_TRY_LINK(, [posix_memalign()], [hdf5_direct_io=yes], [hdf5_direct_io=no]), [hdf5_direct_io=no],)])
if test ${hdf5_direct_io} = "yes"; then
AC_MSG_RESULT([yes])