summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2010-01-26 15:12:08 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2010-01-26 15:12:08 (GMT)
commit855dd92b0e72771df86ec81f5334ffd2add1bfb7 (patch)
treef7eccab42b013c0fa980c82334b4ba7d6733db8f /configure.in
parent65c5e3925d10424b15476112ccac1d0704630316 (diff)
downloadhdf5-855dd92b0e72771df86ec81f5334ffd2add1bfb7.zip
hdf5-855dd92b0e72771df86ec81f5334ffd2add1bfb7.tar.gz
hdf5-855dd92b0e72771df86ec81f5334ffd2add1bfb7.tar.bz2
[svn-r18168] Description:
Code cleanups for better alignment with trunk, along with style issues, etc. Also, get journal test files to work correctly when using a srcdir build. Tested on: Mac OS X/32 10.6.2 (amazon) w/debug, production & parallel (h5committest not required on this branch)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 1843240..2388348 100644
--- a/configure.in
+++ b/configure.in
@@ -68,10 +68,19 @@ AC_OUTPUT_COMMANDS([
else
/bin/mv -f pubconf src/H5pubconf.h
fi
+
echo "Post process src/libhdf5.settings"
sed '/^#/d' < src/libhdf5.settings > libhdf5.settings.TMP
cp libhdf5.settings.TMP src/libhdf5.settings
rm -f libhdf5.settings.TMP
+
+ echo "Unzip large test files"
+ test -d ./test/testfiles || mkdir ./test/testfiles
+ for f in $srcdir/test/testfiles/*.gz; do
+ if test -f $f; then
+ gunzip -c $f > ./test/testfiles/`basename -s .gz $f`
+ fi
+ done
])
dnl It's possible to configure for a host other than the one on which
@@ -3742,17 +3751,6 @@ if test "X${DEFAULT_API_VERSION}" != "Xv18" -a "X${DEPRECATED_SYMBOLS}" = "Xno"
fi
dnl ----------------------------------------------------------------------
-dnl Unzip large test files
-dnl
-AC_MSG_CHECKING([for and unzipping large test files])
-for f in $srcdir/test/testfiles/*.gz; do
- if test -f $f; then
- gunzip -f $f
- fi
-done
-AC_MSG_RESULT([done])
-
-dnl ----------------------------------------------------------------------
dnl Enable strict file format checks
dnl
AC_SUBST([STRICT_FORMAT_CHECKS])