summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2005-04-29 21:39:05 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2005-04-29 21:39:05 (GMT)
commit8f4b37accf49681ff657bcd4496f3bd023895141 (patch)
tree05dd927e8ae8a64357868289d374330966b6d358 /configure.in
parent55f8e19fc7ba1b59f5b435a1e1949457907eff40 (diff)
downloadhdf5-8f4b37accf49681ff657bcd4496f3bd023895141.zip
hdf5-8f4b37accf49681ff657bcd4496f3bd023895141.tar.gz
hdf5-8f4b37accf49681ff657bcd4496f3bd023895141.tar.bz2
[svn-r10700] Purpose:
Bug fix Description: Kent reminded me that switching the logic wasn't enough, we really needed to add the definition to the configure script. Solution: Do that. Platforms tested: FreeBSD 4.11 (sleipnir) Too minor to require h5committest
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5949ed0..46dcbad 100644
--- a/configure.in
+++ b/configure.in
@@ -2623,6 +2623,24 @@ else
fi
dnl ----------------------------------------------------------------------
+dnl Set the flag to indicate that the machine can _compile_
+dnl 'long long' to 'float' and 'double' typecasts.
+dnl (This flag should be set for all machines, except for under Windows when
+dnl compiled with Visual Studio 6, where the macro value is set in the
+dnl src/H5pubconf.h file)
+dnl
+AC_MSG_CHECKING([if compiling long long to floating-point typecasts work])
+AC_CACHE_VAL([hdf5_cv_llong_to_fp_cast_works], [hdf5_cv_llong_to_fp_cast_works=yes])
+
+if test ${hdf5_cv_llong_to_fp_cast_works} = "yes"; then
+ AC_DEFINE([LLONG_TO_FP_CAST_WORKS], [1],
+ [Define if your system can compile long long to floating-point casts.])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+dnl ----------------------------------------------------------------------
dnl Set the flag to indicate that the machine can convert from
dnl 'unsigned long long' to 'long double' without precision loss.
dnl (This flag should be set for all machines, except for FreeBSD(sleipnir)