summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-06-13 21:21:14 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-06-13 21:21:14 (GMT)
commita31e264f8923ba7ea89fefceb7bce7ada4679ee7 (patch)
tree8cf0bb0763c0708d0e343ec179e2dae30df2fe86 /configure.in
parent984bc9d952f03347f571af7f5ea762ddb4d4093a (diff)
downloadhdf5-a31e264f8923ba7ea89fefceb7bce7ada4679ee7.zip
hdf5-a31e264f8923ba7ea89fefceb7bce7ada4679ee7.tar.gz
hdf5-a31e264f8923ba7ea89fefceb7bce7ada4679ee7.tar.bz2
[svn-r12411] Purpose:
Bug fix - bugzilla #552 Description: On Cray X1, trying to use : as an argument confused the system. Solution: Added a test in configure to see if : as an argument is bad. If so, skipped the test. Platforms tested: mir, Cray X1 (change to configure only)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 87342b6..823184f 100644
--- a/configure.in
+++ b/configure.in
@@ -1623,6 +1623,31 @@ int main(void)
,)
dnl ----------------------------------------------------------------------
+dnl Check that a lone colon can be used as an argument
+dnl This is not true on Cray X1, which interprets a lone colon as a
+dnl system command.
+dnl
+AC_CACHE_CHECK([if lone colon can be used as an argument],
+ [hdf5_cv_lone_colon],
+ [
+ echo "int main(int argc, char * argv[]) {return 0;}" > conftest.c
+ $CC $CFLAGS conftest.c > /dev/null 2> /dev/null
+ echo "./a.out :" > conftest.sh
+ chmod 700 conftest.sh
+
+ ./conftest.sh 2> conftest.out
+ TEST_OUTPUT=`cat conftest.out`
+
+ if test "X$TEST_OUTPUT" = "X"; then
+ hdf5_cv_lone_colon=yes
+ else
+ hdf5_cv_lone_colon=no
+ fi
+ ])
+
+AC_SUBST(H5_LONE_COLON) H5_LONE_COLON="$hdf5_cv_lone_colon"
+
+dnl ----------------------------------------------------------------------
dnl Check compiler characteristics
dnl
AC_C_CONST
@@ -3295,6 +3320,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
tools/Makefile
tools/h5dump/Makefile
tools/h5dump/testh5dump.sh
+ tools/h5dump/testh5dumpxml.sh
tools/h5import/Makefile
tools/h5diff/Makefile
tools/h5jam/Makefile