summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-09 18:48:23 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-09 18:48:23 (GMT)
commita46b559c35e84af1724681fa3afe122c22ce783c (patch)
treef273b2e7e217bce595b3997aa2db6ea789403763 /configure.in
parent15e0a2331ecff452c74758ed44b456f06e528860 (diff)
downloadhdf5-a46b559c35e84af1724681fa3afe122c22ce783c.zip
hdf5-a46b559c35e84af1724681fa3afe122c22ce783c.tar.gz
hdf5-a46b559c35e84af1724681fa3afe122c22ce783c.tar.bz2
[svn-r10171] Purpose:
Bug fix Description: The fortran compiler is named FC. If F9X environment variable is set, FC should hold the value in F9X. However, this was overwriting values written to FC by platform-specific config scripts. This caused copper to find the wrong fortran when building in parallel, and may have had other symptoms on other platforms. Solution: Assign $F9X to $FC at the beginning of configure, before platform-specific scripts are run. Do this assignment only if FC is empty. Platforms tested: copper, modi4 (parallel and serial w/c++), verbena. This change should only affect fortran build.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ecbdcdf..6ba1d00 100644
--- a/configure.in
+++ b/configure.in
@@ -67,6 +67,12 @@ dnl set by the code which follows...
dnl
DEFAULT_LIBS=""
+dnl Support F9X variable to define Fortran compiler if FC variable is
+dnl not used. This should be depreciated in the future.
+if test "x" = "x$FC"; then
+ FC=${F9X}
+fi
+
dnl ----------------------------------------------------------------------
dnl Set prefix default (install directory) to a directory in the build area.
dnl This allows multiple src-dir builds within one host.
@@ -273,7 +279,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
dnl General Fortran flags
dnl
FCFLAGS="${FCFLAGS} ${FFLAGS}"
- FC=${F9X}
+
AC_SUBST([F9XSUFFIXFLAG])
AC_SUBST([FSEARCH_DIRS])