summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-02 20:59:46 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-02 20:59:46 (GMT)
commitab243bf369012a88eab45c95b0ea8e96890a3b69 (patch)
tree192fcb53e9e0110f26c88da6d369ca4e58cbf725 /configure.in
parent42d126fa4e174d1f2749ee56275180da99f472a5 (diff)
downloadhdf5-ab243bf369012a88eab45c95b0ea8e96890a3b69.zip
hdf5-ab243bf369012a88eab45c95b0ea8e96890a3b69.tar.gz
hdf5-ab243bf369012a88eab45c95b0ea8e96890a3b69.tar.bz2
[svn-r9920] Purpose:
Bug fix Description: Found the permanant fix to automake/CVS dependency problem Solution: Added AM_MAINTAINER_MODE macro to configure.in. Now automake will never try to regenerate Makefiles, Makefiles.in, configure, H5config.h, etc. when they are out of date, nor will it print any warnings. Developers should be very very careful to use reconfigure script, and can add --enable-maintainer-mode flag to configure on heping to regenerate these files correctly. Platforms tested: heping sleipnir copper
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5c39632..9a889a7 100644
--- a/configure.in
+++ b/configure.in
@@ -32,6 +32,18 @@ AM_CONFIG_HEADER([src/H5config.h])
AC_CONFIG_AUX_DIR([bin])
AM_INIT_AUTOMAKE
+dnl AM_MAINTAINER_MODE turns off "rebuild rules" that contain dependencies
+dnl for Makefiles, configure, src/H5config.h, etc. If AM_MAINTAINER_MODE
+dnl is *not* included here, these files will be rebuilt if out of date.
+dnl This is a problem because if users try to build on a machine with
+dnl the wrong versions of autoconf and automake, these files will be
+dnl rebuilt with the wrong versions and bad things can happen.
+dnl Also, CVS doesn't preserve dependencies between timestamps, so
+dnl Makefiles will often think rebuilding needs to occur when it doesn't.
+dnl Developers should './configure --enable-maintainer-mode' to turn on
+dnl rebuild rules.
+AM_MAINTAINER_MODE
+
AC_OUTPUT_COMMANDS([
echo "creating src/H5pubconf.h"
sed 's/#define /#define H5_/' <src/H5config.h |\