summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2006-06-01 18:34:32 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2006-06-01 18:34:32 (GMT)
commitb1f5c03c79dffa6510a3322e4c63ee77ad3be5d4 (patch)
treec8d56c6a1fffb5c3db4698438155897e2d520976 /configure.in
parent30d130b7b5aaf8422e29005f566cd2caef5558f6 (diff)
downloadhdf5-b1f5c03c79dffa6510a3322e4c63ee77ad3be5d4.zip
hdf5-b1f5c03c79dffa6510a3322e4c63ee77ad3be5d4.tar.gz
hdf5-b1f5c03c79dffa6510a3322e4c63ee77ad3be5d4.tar.bz2
[svn-r12389] Purpose: Bug fix
Description: There was some logical confusion about the value of the macro H5_HW_FP_TO_LLONG_NOT_WORKS. It's supposed to be true for Windows, but false for Unix machines. Solution: Corrected. Platforms tested: fuss(Linux) and amazon(MacOS 10.4) - simple change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5b77514..e1c040b 100644
--- a/configure.in
+++ b/configure.in
@@ -2580,14 +2580,14 @@ dnl (This flag should be _unset_ for all machines, except for Windows, where
dnl it's set in the custom Windows H5pubconf.h file)
dnl
AC_MSG_CHECKING([if converting floating-point values to long long is not working])
-AC_CACHE_VAL([hdf5_cv_convert_float_llong_not_works], [hdf5_cv_convert_float_llong_not_works=yes])
+AC_CACHE_VAL([hdf5_cv_convert_float_llong_not_works], [hdf5_cv_convert_float_llong_not_works=no])
if test ${hdf5_cv_convert_float_llong_not_works} = "yes"; then
AC_DEFINE([HW_FP_TO_LLONG_NOT_WORKS], [1],
[Define if your system can't handle converting floating-point values to long long.])
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([true])
else
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([false])
fi
dnl -----------------------------------------------------------------------