summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-04-04 21:17:51 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-04-04 21:17:51 (GMT)
commitb296a419c4ed2cc43cab53b78a40cbf1346f2362 (patch)
tree7a652352898be1a2e963c9e700228c00a878657d /configure.in
parent7f5e1dfe31696bddb3967865af52801a2b38bb7e (diff)
downloadhdf5-b296a419c4ed2cc43cab53b78a40cbf1346f2362.zip
hdf5-b296a419c4ed2cc43cab53b78a40cbf1346f2362.tar.gz
hdf5-b296a419c4ed2cc43cab53b78a40cbf1346f2362.tar.bz2
[svn-r10534] Purpose:
Configuration feature Description: Different Fortran compilers mangle function names in different ways (upper case, lower case, adding underscores). To link between Fortran and C functions, we need to know what a given function's name is under a given compiler. Solution: Use autoconf's FC_WRAPPERS check to determine the Fortran naming scheme and define the FC_FUNC_ macro to name our functions (in H5f90proto.h). Removed references to our old FNAME macro, as well as flags that indicated whether function names were upper or lower case. Platforms tested: mir, pommier, modi4, copper, more
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 15 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index efd40d3..c7c68a4 100644
--- a/configure.in
+++ b/configure.in
@@ -312,18 +312,23 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_LANG_PUSH(Fortran)
dnl --------------------------------------------------------------------
+ dnl Define wrappers for the C compiler to use Fortran function names
+ dnl
+ AC_FC_WRAPPERS
+
+ dnl --------------------------------------------------------------------
dnl See if the compiler will support the "-I." option
dnl
- FCFLAGS_saved=$FCFLAGS
- FCFLAGS="${FCFLAGS} -I."
-
- AC_MSG_CHECKING(if compiler supports -I. option)
- AC_TRY_FCOMPILE([
- program conftest
- end
- ], AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no)
- FCFLAGS="$FCFLAGS_saved")
+dnl FCFLAGS_saved=$FCFLAGS
+dnl FCFLAGS="${FCFLAGS} -I."
+
+dnl AC_MSG_CHECKING(if compiler supports -I. option)
+dnl AC_TRY_FCOMPILE([
+dnl program conftest
+dnl end
+dnl ], AC_MSG_RESULT(yes),
+dnl AC_MSG_RESULT(no)
+dnl FCFLAGS="$FCFLAGS_saved")
dnl Change back to the C language
AC_LANG_POP(Fortran)