summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2003-01-15 15:57:52 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2003-01-15 15:57:52 (GMT)
commitc41d62c8e5943cd4a129bce3b0b944cbc02c2d7b (patch)
treeb438188cbb28992a265a41f964dc2d5c2d786b1f /configure.in
parent37151401465dfe0882458328de4423b450f72bdc (diff)
downloadhdf5-c41d62c8e5943cd4a129bce3b0b944cbc02c2d7b.zip
hdf5-c41d62c8e5943cd4a129bce3b0b944cbc02c2d7b.tar.gz
hdf5-c41d62c8e5943cd4a129bce3b0b944cbc02c2d7b.tar.bz2
[svn-r6285] Purpose:
a patch Description: When intel compilers (icc, ecc) are used in a linux system, the libtool generated has a wrong setting of '$wl" for linking. Put in a "ed ..." command script to edit the generated libtool with the proper setting. The libtool people has fixed this problem. This can ben taken out when that version of libtool is released. Platforms tested: Tested h5committest {arabica (fortran), eirene (fortran, C++) modi4 (parallel, fortran)}? YES. Other platforms/configurations tested? platinum and titan using gcc and intel CC. Misc. update: Update MANIFEST if you add or remove any file. Update release_docs/RELEASE for bug fixes, new features, etc. Update applicable document files too.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0f3130d..aeaaa39 100644
--- a/configure.in
+++ b/configure.in
@@ -278,6 +278,21 @@ AC_PROG_INSTALL
AC_LIBTOOL_DLOPEN
AC_PROG_LIBTOOL
+dnl Post processing to patch up some deficiencies in libtool
+case $host_os in
+ linux*)
+ # If an Intel compiler is used, it needs to set $wl to use "-Wl,"
+ if $CC -V 2>&1 | grep '^Intel(R)' > /dev/null ; then
+ echo 'fix $wl in' $ofile
+ed - $ofile <<EOF 2> /dev/null
+/^wl=""/s//wl="-Wl,"/
+w
+q
+EOF
+ fi
+ ;;
+esac
+
dnl Fix up the INSTALL macro if it's a relative path. We want the
dnl full-path to the binary instead.
case "$INSTALL" in