summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-10-23 19:33:35 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-10-23 19:33:35 (GMT)
commitc6cb0df0fd21879c6cb03f43cc2d9bcfb3f1ba8a (patch)
treee89e6b3af89fe72620d42d3678e08b003165ab08 /configure.in
parent42e07130b8f2e4f0ab1247e1262bb3eb7333b6d3 (diff)
downloadhdf5-c6cb0df0fd21879c6cb03f43cc2d9bcfb3f1ba8a.zip
hdf5-c6cb0df0fd21879c6cb03f43cc2d9bcfb3f1ba8a.tar.gz
hdf5-c6cb0df0fd21879c6cb03f43cc2d9bcfb3f1ba8a.tar.bz2
[svn-r6027] Purpose:
Update Description: Added new files to the MANIFEST and added a new configure switch for enabling building of the Flexible parallel HDF5 module. Platforms tested: Modi4 Eirene Arabica
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9a70dbc..f7dcd20 100644
--- a/configure.in
+++ b/configure.in
@@ -1722,6 +1722,20 @@ int main(int argc, char **argv)
AC_MSG_RESULT(no),
AC_MSG_RESULT(yes)
CPPFLAGS="$CPPFLAGS -DMPI_GET_COUNT_WORKS",AC_MSG_RESULT(no))
+
+ AC_MSG_CHECKING([if Flexible Parallel HDF5 interface enabled])
+ AC_ARG_ENABLE([fphdf5],
+ [AC_HELP_STRING([--enable-fphdf5],
+ [Enable the Flexible Parallel HDF5
+ interface])],
+ [FPHDF5=$enableval])
+ if test "X$FPHDF5" = "Xyes"; then
+ AC_DEFINE(HAVE_FPHDF5, 1,
+ [Define if we want flexible parallel HDF5 support])
+ echo "yes"
+ else
+ echo "no"
+ fi
fi
dnl ----------------------------------------------------------------------