summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2007-02-28 16:54:50 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2007-02-28 16:54:50 (GMT)
commitc8ba250a1e2db0d4d66705a131841f5cc1c86a2d (patch)
tree3143dad02fe5398332cd5c1bd8f457d19190f90c /configure.in
parenta9d32e4896e6577a0fa8380632f45b7f82a34fcb (diff)
downloadhdf5-c8ba250a1e2db0d4d66705a131841f5cc1c86a2d.zip
hdf5-c8ba250a1e2db0d4d66705a131841f5cc1c86a2d.tar.gz
hdf5-c8ba250a1e2db0d4d66705a131841f5cc1c86a2d.tar.bz2
[svn-r13432] Changed the detection of alignment requirement for Direct I/O from configuration to run-time
detection in H5FD_direct_open in H5FDdirect.c.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 0 insertions, 40 deletions
diff --git a/configure.in b/configure.in
index ae39c27..eadf1fe 100644
--- a/configure.in
+++ b/configure.in
@@ -2644,46 +2644,6 @@ fi
AM_CONDITIONAL([DIRECT_VFD_CONDITIONAL], [test "X$DIRECT_VFD" = "Xyes"])
dnl ----------------------------------------------------------------------
-dnl Check if Direct I/O driver requires alignment.
-dnl
-
-if test ${hdf5_direct_io} = "yes"; then
- AC_MSG_CHECKING([for Direct VFD alignment requirement])
-
- AC_CACHE_VAL([hdf5_direct_align],
- [AC_TRY_RUN([
- #include <stdlib.h>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
- int main(void)
- {
- int *buf;
- int fid;
- fid=open("tst_file", O_CREAT | O_TRUNC | O_DIRECT | O_RDWR, 0755);
- buf = (int*)malloc(sizeof(int));
- if(write(fid, (void*)buf, sizeof(int))<0) {
- close(fid);
- free(buf);
- remove("tst_file");
- exit(1);
- }
- close(fid);
- remove("tst_file");
- free(buf);
- exit (0);
- }], [hdf5_direct_align=no], [hdf5_direct_align=yes],)])
-
- if test ${hdf5_direct_align} = "yes"; then
- AC_MSG_RESULT([yes])
- AC_DEFINE([HAVE_DIRECT_ALIGN], [1],
- [Define if the direct I/O VFD requires alignment])
- else
- AC_MSG_RESULT([no])
- fi
-fi
-
-dnl ----------------------------------------------------------------------
dnl Decide whether the presence of user's exception handling functions is
dnl checked and data conversion exceptions are returned. This is mainly
dnl for the speed optimization of hard conversions. Soft conversions can