summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2003-01-30 22:20:13 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2003-01-30 22:20:13 (GMT)
commitceec9c45d9345bb6e864a492ad49932537dd4fdc (patch)
treef5f5378eab3a5032264921b1e154159252a8dbb7 /configure.in
parent1e35713691e20b00fa3458c77391fbc84efbb7a5 (diff)
downloadhdf5-ceec9c45d9345bb6e864a492ad49932537dd4fdc.zip
hdf5-ceec9c45d9345bb6e864a492ad49932537dd4fdc.tar.gz
hdf5-ceec9c45d9345bb6e864a492ad49932537dd4fdc.tar.bz2
[svn-r6353] Purpose:
Update Description: Updated the configure scripts. Fortran and C++ didn't have proper checks for Linux LFS support. Also needed to remove the "-g" flag from the compile line if --enable-production is set. For that, I took how it's being done in HDF5 Lite... Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 69b2cd6..f6d983b 100644
--- a/configure.in
+++ b/configure.in
@@ -442,6 +442,19 @@ case "X-$enable_production" in
X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
+
+ dnl Remove the "-g" flag from CFLAGS if it's in there.
+ dnl
+ CFLAGS_temp=""
+ if test -n "$CFLAGS"; then
+ for d in $CFLAGS ; do
+ if test "X$d" != "X-g"; then
+ CFLAGS_temp="$CFLAGS_temp $d"
+ fi
+ done
+ CFLAGS=$CFLAGS_temp
+ fi
+
CONFIG_MODE=production
CFLAGS="$CFLAGS $PROD_CFLAGS"
CPPFLAGS="$CPPFLAGS $PROD_CPPFLAGS"