summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2001-09-04 21:18:59 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2001-09-04 21:18:59 (GMT)
commitdc5a388f8d2093cb7f43d6d93c9f6fb055fde58a (patch)
tree74b1abe8c4e936d7c2dbc6a9110604c11663348d /configure.in
parent1e3185431d8258625203577de60d2f437888c24c (diff)
downloadhdf5-dc5a388f8d2093cb7f43d6d93c9f6fb055fde58a.zip
hdf5-dc5a388f8d2093cb7f43d6d93c9f6fb055fde58a.tar.gz
hdf5-dc5a388f8d2093cb7f43d6d93c9f6fb055fde58a.tar.bz2
[svn-r4422] Purpose:
Portability Bug Fixes Description: FreeBSD wants the -pthread flag on both the compile and link lines. Also, the cipher library is required for certain threading features and needs to be linked in. Solution: Add the -pthread to the compile line and the cipher library to the list of libraries. Platforms tested: FreeBSD 4.4 (hawkwind)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 502bc8d..97f5ebb 100644
--- a/configure.in
+++ b/configure.in
@@ -976,8 +976,9 @@ case "$withval" in
if test `uname` != "FreeBSD"; then
AC_CHECK_LIB(pthread, pthread_create,,unset PTHREAD)
else
- CFLAGS="$CFLAGS -D_THREAD_SAFE"
+ CFLAGS="$CFLAGS -pthread -D_THREAD_SAFE"
LDFLAGS="$LDFLAGS -pthread"
+ LIBS="$LIBS -lcipher"
fi
;;
no)