summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2003-07-03 21:20:33 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2003-07-03 21:20:33 (GMT)
commit76ae1a3f451db2f91ad70975282ff25ae0c68ace (patch)
treef7a0820e794dfc9f501e515ed9343433a4afd22c /configure.in
parentf43ea3be020de9aec24b0871654697522f99b52c (diff)
downloadhdf5-76ae1a3f451db2f91ad70975282ff25ae0c68ace.zip
hdf5-76ae1a3f451db2f91ad70975282ff25ae0c68ace.tar.gz
hdf5-76ae1a3f451db2f91ad70975282ff25ae0c68ace.tar.bz2
[svn-r7166] Purpose:
Update configuration Description: Now that we've split the tree (Yea!), change the main trunk back to debug on and production off. Also, change the version # to 1.7.0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 2512974..20b14c6 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,7 @@ dnl
dnl NOTE: Don't forget to change the version number here when we do a
dnl release!!!
dnl
-AC_INIT([HDF5], [1.6.0-pre1], [hdfhelp@ncsa.uiuc.edu])
+AC_INIT([HDF5], [1.7.0], [hdfhelp@ncsa.uiuc.edu])
AC_CONFIG_SRCDIR([src/H5.c])
AC_CONFIG_HEADER([src/H5config.h])
@@ -439,7 +439,7 @@ AC_ARG_ENABLE(production,
[Determines how to run the compiler.])])
case "X-$enable_production" in
- X-|X-yes)
+ X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
@@ -459,7 +459,7 @@ case "X-$enable_production" in
CFLAGS="$CFLAGS $PROD_CFLAGS"
CPPFLAGS="$CPPFLAGS $PROD_CPPFLAGS"
;;
- X-no)
+ X-|X-no)
enable_production="no"
AC_MSG_RESULT([development])
CONFIG_MODE=development
@@ -1630,7 +1630,7 @@ AC_ARG_ENABLE([debug],
AC_SUBST([DEBUG_PKG])
all_packages="ac,b,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
- X-yes)
+ X-|X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(default ($DEBUG_PKG))
@@ -1640,7 +1640,7 @@ case "X-$DEBUG_PKG" in
CPPFLAGS="$CPPFLAGS -UNDEBUG"
AC_MSG_RESULT(all ($DEBUG_PKG))
;;
- X-|X-no|X-none)
+ X-no|X-none)
AC_MSG_RESULT(none)
DEBUG_PKG=
CPPFLAGS="$CPPFLAGS -DNDEBUG"