summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-16 20:16:00 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-16 20:16:00 (GMT)
commitdfb22d02b04f70beb06e1280e2080ae32d4c20c1 (patch)
treea7a9b428669d9ffe972e5a07279f80f4a3c895dd /configure.in
parent091fb5951ca8845a1679b8dc474a63ade63260a9 (diff)
downloadhdf5-dfb22d02b04f70beb06e1280e2080ae32d4c20c1.zip
hdf5-dfb22d02b04f70beb06e1280e2080ae32d4c20c1.tar.gz
hdf5-dfb22d02b04f70beb06e1280e2080ae32d4c20c1.tar.bz2
[svn-r17663] Purpose:
configure cleanup Description 1. Removed check that disables shared libraries when pgcc is used. Apparently they previously did not work with libtool 1.5.14 and on mir, neither of which is in use anymore. Testing on jam and amani appear fine, so this check is unnecessary. 2. Removed check that disables shared C++ libraries when -xarch is used to enable 64 bit mode. We now use m64 flag to build 64 bit binaries, so we shouldn't explicitly disable shared C++ libraries if -xarch is discovered. 3. Removed old configure output summary section from configure.in, since we now use the libhdf5.settings file. 4. Updated powerpc-ibm-aix5.x config file to once again put c99 flag into H5_CFLAGS (and thus NOT get into h5cc), as decided in our dev meeting. Tested: h5committest full build with pgcc on jam / amani
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in232
1 files changed, 2 insertions, 230 deletions
diff --git a/configure.in b/configure.in
index 446ded0..f09f0f0 100644
--- a/configure.in
+++ b/configure.in
@@ -864,18 +864,6 @@ elif test "X${enable_shared}" = "Xyes" -a "X${PARALLEL}" != "X"; then
fi
dnl ----------------------------------------------------------------------
-dnl As of Libtool 1.5.14, libtool officially doesn't know how to create
-dnl shared libraries with pgcc. In fact, it is able to do so on some
-dnl platforms, but not all (e.g., pgcc 5.2-4 on mir).
-dnl Disable shared libraries when using pgcc. -JL 09/2005
-if test "X${enable_shared}" != "Xno" && \
- (${CC-cc} -V 2>&1 | grep '^pgcc') > /dev/null; then
- echo ' warning: shared libraries are not supported for pgcc!'
- echo ' disabling shared libraries'
- enable_shared="no"
-fi
-
-dnl ----------------------------------------------------------------------
dnl Many Fortran compilers don't support shared libraries. Some of these
dnl compilers include:
dnl pgf90 version 6.0-4
@@ -919,24 +907,13 @@ fi
AM_CONDITIONAL([FORTRAN_SHARED_CONDITIONAL], [test "X$H5_FORTRAN_SHARED" = "Xyes"])
-dnl ----------------------------------------------------------------------
-dnl Shared C++ libraries seem not to work on some platforms (modi4, shanti)
-dnl when the -xarch=v9 flag is used to enable 64-bit mode.
-dnl Try to detect the -xarch=v9 flag and disable C++ shared libraries if it's
-dnl being used.
-dnl Also disable C++ shared libraries if shared libraries are disabled.
-dnl this prevents Automake from trying to link against shared libraries,
+dnl Disable C++ shared libraries if shared libraries are disabled.
+dnl This prevents Automake from trying to link against shared libraries,
dnl which caused problems on tg-login
H5_CXX_SHARED="no"
if test "X${HDF_CXX}" = "Xyes" && test "X${enable_shared}" != "Xno"; then
H5_CXX_SHARED="yes"
- if (echo dummy ${CXX} ${CXXLD} ${CFLAGS} ${CXXFLAGS} ${LDFLAGS} | grep 'xarch') > /dev/null; then
- echo " warning: -xarch flag detected"
- echo " disabling shared C++ libraries"
- H5_CXX_SHARED="no"
- fi
-
dnl Try to detect the +DD64 flag for HPUX aCC compiler and disable C++ shared libraries if it's
dnl being used.
@@ -4170,208 +4147,3 @@ EOF
dnl show the configure settings
cat src/libhdf5.settings
-
-if false; then
-dnl ============ old code to be removed ================
-dnl ----------------------------------------------------------------------
-dnl Print out a summary of what we are going to build.
-dnl
-if test -z "$ECHO_N" -o -z "$ECHO_C"; then
- if (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; then
- if (echo -n testing; echo 1,2,3) | sed s/-n/xn/ | grep xn >/dev/null; then
- ECHO_N=''
- ECHO_C='
-'
- else
- ECHO_N=-n
- ECHO_C=''
- fi
- else
- ECHO_N=''
- ECHO_C='\c'
- fi
-fi
-
-PRINT_PLAIN() {
- echo $ECHO_N "$1$ECHO_C"
- echo $ECHO_N "$1$ECHO_C" 1>>src/libhdf5.settings
-}
-
-PRINT_N() {
- echo $ECHO_N "$1: $ECHO_C"
- echo $ECHO_N "$1: $ECHO_C" 1>>src/libhdf5.settings
-}
-
-PRINT() {
- echo "$1"
- echo "$1" 1>>src/libhdf5.settings
-}
-
-dnl ----------------------------------------------------------------------
-dnl Print "Yes" if all arguments are "yes", otherwise "No"
-dnl
-IF_YES_NO() {
- if test $# -lt 1; then
- PRINT "No"
- return
- else
- while test $# -gt 0; do
- if test "$1" != "yes"; then
- PRINT "No"
- return
- fi
- shift
- done
- fi
- PRINT "Yes"
-}
-
-IF_ENABLED_DISABLED() {
- if test "$1" = "yes"; then
- PRINT "Enabled"
- else
- PRINT "Disabled"
- fi
-}
-
-PRINT ""
-PRINT " Configure Summary"
-PRINT " ================="
-PRINT ""
-PRINT "Compiling Options:"
-PRINT "------------------"
-
-PRINT_N " Compilation Mode"
-case "X-$enable_production" in
- X-yes) PRINT "Production" ;;
- X-no) PRINT "Development" ;;
- X-profile) PRINT "Profile" ;;
- *) PRINT "$enable_production" ;;
-esac
-
-PRINT_N " C Compiler"
-PRINT "$CC"
-
-PRINT_N " CFLAGS / H5_CFLAGS"
-PRINT "$CFLAGS"
-PRINT " $H5_CFLAGS"
-
-PRINT_N " CPPFLAGS / H5_CPPFLAGS"
-PRINT "$CPPFLAGS"
-PRINT " $H5_CPPFLAGS"
-
-PRINT_N " LDFLAGS"
-PRINT "$LDFLAGS"
-
-PRINT_N " Debug Mode"
-
-if test "X$DEBUG_PKG" = "X$all_packages"; then
- PRINT "All"
-elif test "X$DEBUG_PKG" = "X"; then
- PRINT "None"
-else
- PRINT $DEBUG_PKG
-fi
-
-PRINT_N " Shared Libraries"
-IF_YES_NO "$enable_shared"
-
-PRINT_N " Static Libraries"
-IF_YES_NO "$enable_static"
-
-PRINT_N " Statically Linked Executables"
-IF_YES_NO "$STATIC_EXEC"
-
-PRINT_N "Default Version of Public Symbols"
-PRINT $DEFAULT_API_VERSION
-
-PRINT_N " With Deprecated Public Symbols"
-IF_YES_NO "$DEPRECATED_SYMBOLS"
-
-PRINT_N " Tracing"
-IF_YES_NO "$TRACE_API"
-
-PRINT_N "Clear file buffers before write"
-IF_YES_NO "$CLEARFILEBUF"
-
-PRINT_N " Using memory checker"
-IF_YES_NO "$USINGMEMCHECKER"
-
-PRINT_N " Optimization Instrumentation"
-IF_YES_NO "$INSTRUMENT"
-
-PRINT ""
-PRINT "Languages:"
-PRINT "----------"
-
-PRINT_N " C++"
-IF_YES_NO "$HDF_CXX"
-if test X$HDF_CXX = Xyes; then
- PRINT_N " C++ Compiler"
- PRINT "$CXX"
-
- PRINT_N " CXXFLAGS / H5_CXXFLAGS"
- PRINT "$CXXFLAGS"
- PRINT " $H5_CXXFLAGS"
-fi
-
-PRINT_N " Fortran"
-IF_YES_NO "$HDF_FORTRAN"
-if test X$HDF_FORTRAN = Xyes; then
- PRINT_N " Fortran Compiler"
- PRINT "$FC"
-
- PRINT_N " FCFLAGS / H5_FCFLAGS"
- PRINT "$FCFLAGS"
- PRINT " $H5_FCFLAGS"
-fi
-
-PRINT ""
-PRINT "Features:"
-PRINT "---------"
-
-PRINT_N " dmalloc"
-IF_YES_NO "$HAVE_DMALLOC"
-
-PRINT_N " Function Stack Tracing"
-IF_ENABLED_DISABLED "$CODESTACK"
-
-PRINT_N " GPFS"
-IF_YES_NO "$GPFS"
-
-PRINT_N " Strict File Format Checks"
-IF_ENABLED_DISABLED "$STRICT_FORMAT_CHECKS"
-
-PRINT_N " Default API Mapping"
-PRINT "$DEFAULT_API_VERSION"
-
-PRINT_N " I/O filters (external)"
-PRINT "$EXTERNAL_FILTERS"
-
-PRINT_N " I/O filters (internal)"
-PRINT "$FILTERS"
-
-PRINT_N " Linux Large File Support (LFS)"
-IF_ENABLED_DISABLED "$LINUX_LFS"
-
-PRINT_N " MPE"
-IF_YES_NO "$MPE"
-
-
-PRINT_N " Parallel HDF5"
-if test "$PARALLEL" != "no"; then
- PRINT "Yes"
-else
- PRINT "No"
-fi
-
-
-PRINT_N " Direct VFD"
-IF_ENABLED_DISABLED "$DIRECT_VFD"
-
-PRINT_N " Threadsafety"
-IF_ENABLED_DISABLED "$THREADSAFE"
-
-PRINT_N " High Level library"
-IF_ENABLED_DISABLED "$HDF5_HL"
-fi