summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2001-08-06 16:01:44 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2001-08-06 16:01:44 (GMT)
commit41529d180ebc129f831d9bfea162e377d598fe92 (patch)
tree8df90e91eecd382f91c7b6e81aff192db208bc31 /configure.in
parent2a39beb49bed12fa0385fbae4c2f118f5809e842 (diff)
downloadhdf5-41529d180ebc129f831d9bfea162e377d598fe92.zip
hdf5-41529d180ebc129f831d9bfea162e377d598fe92.tar.gz
hdf5-41529d180ebc129f831d9bfea162e377d598fe92.tar.bz2
[svn-r4312] Purpose:
Feature shift Description: Take out the v1.2.x compatibility stubs and put in the hooks for v1.4.x compatibility when needed. Platforms tested: FreeBSD 4.3 (hawkwind)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 984b099..7c6dd05 100644
--- a/configure.in
+++ b/configure.in
@@ -988,17 +988,17 @@ if test "X$THREADSAFE" = "Xyes"; then
fi
dnl ----------------------------------------------------------------------
-dnl Check if they would like the HDF5 v1.2 compatibility functions
+dnl Check if they would like the HDF5 v1.4 compatibility functions
dnl compiled in
dnl
-AC_MSG_CHECKING(whether HDF5 v1.2 compatibility functions enabled)
-AC_ARG_ENABLE(hdf5v1_2,
- [ --enable-hdf5v1_2 Compile the HDF5 v1.2 compatibility interface [default=no]],
- HDF5_V1_2_COMPAT=$enableval)
+AC_MSG_CHECKING(whether HDF5 v1.4 compatibility functions enabled)
+AC_ARG_ENABLE(hdf5v1_4,
+ [ --enable-hdf5v1_4 Compile the HDF5 v1.4 compatibility interface [default=no]],
+ HDF5_V1_4_COMPAT=$enableval)
-if test "X$HDF5_V1_2_COMPAT" = "Xyes"; then
+if test "X$HDF5_V1_4_COMPAT" = "Xyes"; then
AC_MSG_RESULT(yes)
- AC_DEFINE(WANT_H5_V1_2_COMPAT)
+ AC_DEFINE(WANT_H5_V1_4_COMPAT)
else
AC_MSG_RESULT(no)
fi