summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2011-04-26 21:41:41 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2011-04-26 21:41:41 (GMT)
commitb6edc2873a0137d8129489ad412372489ea686bf (patch)
tree09e9e86c5f411f44a7cd83db0102157b007852ca /configure.in
parent14f7bcf8c954738d103f43c3be5162c2600bb4dc (diff)
downloadhdf5-b6edc2873a0137d8129489ad412372489ea686bf.zip
hdf5-b6edc2873a0137d8129489ad412372489ea686bf.tar.gz
hdf5-b6edc2873a0137d8129489ad412372489ea686bf.tar.bz2
[svn-r20651] Description:
Switch from using 'pthread_create' to 'pthread_self' when trying to detect the pthread library, so that the Intel C compiler is happier with the prototype. Tested on: Linux/64 2.6 (koala) w/Intel C (h5committested on duty, jam & linew)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 9d56f4d..003d8fb 100644
--- a/configure.in
+++ b/configure.in
@@ -1839,7 +1839,7 @@ AC_ARG_WITH([pthread],
case "$withval" in
yes)
AC_CHECK_HEADERS([pthread.h])
- AC_CHECK_LIB([pthread], [pthread_create],, [unset PTHREAD])
+ AC_CHECK_LIB([pthread], [pthread_join],, [unset PTHREAD])
;;
no)
AC_MSG_CHECKING([for pthread])
@@ -1884,11 +1884,11 @@ case "$withval" in
saved_AM_LDFLAGS="$AM_LDFLAGS"
LDFLAGS="$LDFLAGS -L$pthread_lib"
AM_LDFLAGS="$AM_LDFLAGS -L$pthread_lib"
- AC_CHECK_LIB([pthread], [pthread_create],,
+ AC_CHECK_LIB([pthread], [pthread_join],,
[LDFLAGS="$saved_LDFLAGS"; AM_LDFLAGS="$saved_AM_LDFLAGS"; unset PTHREAD])
else
- AC_CHECK_LIB([pthread], [pthread_create],, [unset PTHREAD])
+ AC_CHECK_LIB([pthread], [pthread_join],, [unset PTHREAD])
fi
;;
esac
@@ -1908,7 +1908,7 @@ case "X-$THREADSAFE" in
;;
X-yes)
dnl Check that we can link a simple Pthread program.
- AC_TRY_LINK(, [pthread_create()],
+ AC_TRY_LINK(, [pthread_join()],
[AC_MSG_RESULT([yes]); THREADSAFE=yes],
[AC_MSG_ERROR([needed pthread library not available])])
;;