summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2011-04-28 00:56:57 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2011-04-28 00:56:57 (GMT)
commitde925f4b385044e2873cf07c3179ce80f56c8c80 (patch)
tree6d6b0bc627f1431f2629072e3095325376377b35 /configure.in
parent389c88e87cc9c7d71ed9ca792c829a5cc0bae5e6 (diff)
downloadhdf5-de925f4b385044e2873cf07c3179ce80f56c8c80.zip
hdf5-de925f4b385044e2873cf07c3179ce80f56c8c80.tar.gz
hdf5-de925f4b385044e2873cf07c3179ce80f56c8c80.tar.bz2
[svn-r20657] Description:
Correct check for pthreads routine from pthread_join() to pthread_self() as intended. Tested on FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode FreeBSD/32 8.2 (loyalty) w/gcc4.6, w/C++ & FORTRAN, in debug mode FreeBSD/64 8.2 (freedom) w/gcc4.6, w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/default API=1.8.x, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (koala) w/Intel compilers, w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, w/threadsafe, in production mode Linux/PPC 2.6 (heiwa) w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-ia64 2.6 (ember) w/Intel compilers, w/C++ & FORTRAN, in production mode Linux/64-amd64 2.6 (abe) w/parallel, w/FORTRAN, in debug mode
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 003d8fb..66cd0e6 100644
--- a/configure.in
+++ b/configure.in
@@ -1839,7 +1839,7 @@ AC_ARG_WITH([pthread],
case "$withval" in
yes)
AC_CHECK_HEADERS([pthread.h])
- AC_CHECK_LIB([pthread], [pthread_join],, [unset PTHREAD])
+ AC_CHECK_LIB([pthread], [pthread_self],, [unset PTHREAD])
;;
no)
AC_MSG_CHECKING([for pthread])
@@ -1884,11 +1884,11 @@ case "$withval" in
saved_AM_LDFLAGS="$AM_LDFLAGS"
LDFLAGS="$LDFLAGS -L$pthread_lib"
AM_LDFLAGS="$AM_LDFLAGS -L$pthread_lib"
- AC_CHECK_LIB([pthread], [pthread_join],,
+ AC_CHECK_LIB([pthread], [pthread_self],,
[LDFLAGS="$saved_LDFLAGS"; AM_LDFLAGS="$saved_AM_LDFLAGS"; unset PTHREAD])
else
- AC_CHECK_LIB([pthread], [pthread_join],, [unset PTHREAD])
+ AC_CHECK_LIB([pthread], [pthread_self],, [unset PTHREAD])
fi
;;
esac
@@ -1908,7 +1908,7 @@ case "X-$THREADSAFE" in
;;
X-yes)
dnl Check that we can link a simple Pthread program.
- AC_TRY_LINK(, [pthread_join()],
+ AC_TRY_LINK(, [pthread_self()],
[AC_MSG_RESULT([yes]); THREADSAFE=yes],
[AC_MSG_ERROR([needed pthread library not available])])
;;