summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobert E. McGrath <mcgrath@ncsa.uiuc.edu>2004-11-02 19:10:24 (GMT)
committerRobert E. McGrath <mcgrath@ncsa.uiuc.edu>2004-11-02 19:10:24 (GMT)
commitf7c4277bbbbe531ba37b36bb6b2e1b3f2966efea (patch)
tree1009412864e2631092c511506477c2b30671bcbe /configure.in
parentc9874681a6b5056598a5170faecad9b29640fbba (diff)
downloadhdf5-f7c4277bbbbe531ba37b36bb6b2e1b3f2966efea.zip
hdf5-f7c4277bbbbe531ba37b36bb6b2e1b3f2966efea.tar.gz
hdf5-f7c4277bbbbe531ba37b36bb6b2e1b3f2966efea.tar.bz2
[svn-r9493] Purpose:
Fix SZIP filter to dynmically detect encoder. Description: Solution: See: http://hdf.ncsa.uiuc.edu/RFC/SZIP/Szip_dynamic_12_Oct.pdf Platforms tested: verbena, arabica, cobalt. Note RE testing: All automatic tests work as before. The feature is a configuration thing, so the tests are manual. Tested with the following configs: pre-release version of SZIP, with dynamic library, 1. no SZIP 2. SZIP, decoder only 3. SZIP, encoder+decoder released (static lib) SZIP 4. no SZIP 5. SZIP, decoder only 6. SZIP, encoder+decoder after build, switch szip in LD_LIBRARY_PATH at run time 7. SZIP decoder 8. SZIP encoder Misc. update: Manifest updated
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d3033ae..191e89a 100644
--- a/configure.in
+++ b/configure.in
@@ -1043,7 +1043,6 @@ dnl command-line switch. The value is an include path and/or a library path.
dnl If the library path is specified then it must be preceded by a comma.
dnl
AC_SUBST(USE_FILTER_SZIP) USE_FILTER_SZIP="no"
-AC_SUBST(USE_FILTER_SZIP_ENCODER) USE_FILTER_SZIP_ENCODER="no"
AC_ARG_WITH([szlib],
[AC_HELP_STRING([--with-szlib=DIR],
[Use szlib library for external szlib I/O
@@ -1136,10 +1135,7 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
], [hdf5_cv_szlib_can_encode=yes], [hdf5_cv_szlib_can_encode=no],)])
if test ${hdf5_cv_szlib_can_encode} = "yes"; then
- AC_DEFINE([SZIP_CAN_ENCODE], [1],
- [Define if szip encoder is present])
AC_MSG_RESULT([yes])
- USE_FILTER_SZIP_ENCODER="yes"
else
AC_MSG_RESULT([no])
fi
@@ -1149,6 +1145,11 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
EXTERNAL_FILTERS="${EXTERNAL_FILTERS},"
fi
EXTERNAL_FILTERS="${EXTERNAL_FILTERS}szip"
+ if test ${hdf5_cv_szlib_can_encode} = "yes"; then
+ EXTERNAL_FILTERS="${EXTERNAL_FILTERS}(encoder)"
+ else
+ EXTERNAL_FILTERS="${EXTERNAL_FILTERS}(no encoder)"
+ fi
fi
dnl ----------------------------------------------------------------------