summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2011-05-23 17:02:39 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2011-05-23 17:02:39 (GMT)
commitc8d91d05a40a05e0d73202ad1348294a5446d42e (patch)
treebe35eb0deb5469b98314fbfc6c049ebcd2619b6e /configure.in
parent0db46e50d264ae7b572a0ac118c2bf3e7d54ccf9 (diff)
downloadhdf5-c8d91d05a40a05e0d73202ad1348294a5446d42e.zip
hdf5-c8d91d05a40a05e0d73202ad1348294a5446d42e.tar.gz
hdf5-c8d91d05a40a05e0d73202ad1348294a5446d42e.tar.bz2
[svn-r20891] Purpose:
Changes configure/configure.in to use the same CFLAGS and CPPFLAGS in the configure tests that are used to build the library. Description: Only AM_CPPFLAGS was propagated to the CPPFLAGS that were used to build the library. Now H5_CPPFLAGS, AM_CFLAGS and H5_CFLAGS are used in the configure tests. Tested on: jam(linux32-LE) freedom(bsd63-LE) linew(solaris-BE) tejeda(darwin32 LE)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 0dcab5f..f1c0383 100644
--- a/configure.in
+++ b/configure.in
@@ -1391,9 +1391,11 @@ case "$host_cpu-$host_vendor-$host_os" in
;;
esac
-dnl Need to add AM_CPPFLAGS into CPPFLAGS to make them visible for configure checks.
-dnl Note: CPPFLAGS will be restored by the end of configure.
-CPPFLAGS="$AM_CPPFLAGS $CPPFLAGS"
+dnl Need to add the AM_ and H5_ into CPFLAGS/CPPFLAGS to make them visible
+dnl for configure checks.
+dnl Note: Both will be restored by the end of configure.
+CPPFLAGS="$H5_CPPFLAGS $AM_CPPFLAGS $CPPFLAGS"
+CFLAGS="$H5_CFLAGS $AM_CFLAGS $CFLAGS"
AC_TRY_COMPILE([#include <sys/types.h>],
[off64_t n = 0;],