summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-03-09 17:50:53 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-03-09 17:50:53 (GMT)
commitda5058310c324dcce93dc9328ef2bd53bf1fed02 (patch)
treefb079da5b113904f61c922ed02f59fe84e8e9d9f /configure.in
parent793503a3cd26b3435ee27b092d9fe7f2cb93ce29 (diff)
downloadhdf5-da5058310c324dcce93dc9328ef2bd53bf1fed02.zip
hdf5-da5058310c324dcce93dc9328ef2bd53bf1fed02.tar.gz
hdf5-da5058310c324dcce93dc9328ef2bd53bf1fed02.tar.bz2
[svn-r16554] Purpose:
Bug Fix Description: Removing the code from configure which strips the '-g' flag from CFLAGS when in production mode. The current default CFLAGS in production mode does not include '-g', as intended, but we should allow users to override this and enable '-g' by setting the CFLAGS environment variable if desired. Note that this applies to FCFLAGS and CXXFLAGS as well. Tested: kagiso, linew, liberty
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.in b/configure.in
index 32d9d59..229209d 100644
--- a/configure.in
+++ b/configure.in
@@ -1142,39 +1142,6 @@ case "X-$enable_production" in
X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
-
- dnl Remove the "-g" flag from CFLAGS if it's in there.
- dnl
- CFLAGS_temp=""
- if test -n "$CFLAGS"; then
- for d in $CFLAGS ; do
- if test "X$d" != "X-g"; then
- CFLAGS_temp="$CFLAGS_temp $d"
- fi
- done
- CFLAGS=$CFLAGS_temp
- fi
-
- CXXFLAGS_temp=""
- if test -n "$CXXFLAGS"; then
- for d in $CXXFLAGS ; do
- if test "X$d" != "X-g"; then
- CXXFLAGS_temp="$CXXFLAGS_temp $d"
- fi
- done
- CXXFLAGS=$CXXFLAGS_temp
- fi
-
- FCFLAGS_temp=""
- if test -n "$FCFLAGS"; then
- for d in $FCFLAGS ; do
- if test "X$d" != "X-g"; then
- FCFLAGS_temp="$FCFLAGS_temp $d"
- fi
- done
- FCFLAGS=$FCFLAGS_temp
- fi
-
CONFIG_MODE=production
H5_CFLAGS="$H5_CFLAGS $PROD_CFLAGS"
H5_CPPFLAGS="$H5_CPPFLAGS $PROD_CPPFLAGS"