summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2011-07-14 20:33:21 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2011-07-14 20:33:21 (GMT)
commitdc9288a44706fa89558d218325f34dbfdad31d07 (patch)
tree04fd24b7f047af98763c5b4b8a830622312b43fd /configure.in
parent3397a114ced762dd088c674ff9bca5a950428927 (diff)
downloadhdf5-dc9288a44706fa89558d218325f34dbfdad31d07.zip
hdf5-dc9288a44706fa89558d218325f34dbfdad31d07.tar.gz
hdf5-dc9288a44706fa89558d218325f34dbfdad31d07.tar.bz2
[svn-r21101] HDFFV-7639
Purpose: Remove H5_MPI_SPECIAL_COLLECTIVE_IO_WORKS and H5_MPI_COMPLEX_DERIVED_DATATYPE_WORKS #defines from source. Description: Two advanced parallel functionalities, special collective IO and complex derived datatypes, are not supported by older implementations of mpi, and thus our code limits the use of these features with #ifdefs and has checks in configure to set them (or not). Unfortunately, configure can't actually run a parallel check to see if these features are working (nor not) so it resorts to looking in the config files where they are explicity enabled or disabled based on versions of mpi, sytems being built on, or for no documented reason at all (i.e. just set to on or off as some 'default'). Overriding these settings is easy if need be, provided it is known that it needs to be done to get improved performance, and oftentimes it is not. Most new MPI implementations successfully handle the functionality requested when these #defines are set, and many of the "turn these features off" cases in the config files are for old (> 5 years) versions of MPI and retired systems (such as NCSA's tungsten). Therefore, the decision has been made to remove the support for these old versions of MPI and systems that cannot handle these behaviors. The #ifdefs and supporting setup in the config/ files and configure script has been removed, and the code executed when these options were not set removed from the source. In passing, this commit also cleans up some whitespace issues in both t_mpi.c and H5Dmpio.c. Furthermore, in t_mpi.c, the special collective IO test was not getting regularly run due to it being written to work only with four processes (we regularly test with six, previously with three), and thus it failed when actually run due to an out of bounds data buffer assignment. It has been modified to run at any number of processes greater than four, and the memory problem has been fixed so the test passes. Tested: jam, h5committest, ember
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in100
1 files changed, 30 insertions, 70 deletions
diff --git a/configure.in b/configure.in
index 1ba585b..222d0f8 100644
--- a/configure.in
+++ b/configure.in
@@ -2796,76 +2796,36 @@ if test -n "$PARALLEL"; then
AC_MSG_RESULT([no])
fi
-dnl ----------------------------------------------------------------------
-dnl Set the flag to indicate that the MPI_File_get_size() function
-dnl works. The default is enabled unless the user knows the function
-dnl doesn't work on the system and disables it. (This flag should be set
-dnl for all machines except for SGI Altix Propack 4 where the function
-dnl doesn't return correct file size.)
-dnl
-AC_ARG_ENABLE([mpi-size],
- [AC_HELP_STRING([--enable-mpi-size],
- [Some systems (only SGI Altix Propack 4 so far) return wrong value
- from MPI_File_get_size. By disabling this function, the library
- will replace it with stat to get the correct file size.
- [default=yes]])],
- [MPI_GET_SIZE=$enableval])
-
-AC_MSG_CHECKING([if MPI_File_get_size is enabled])
-
-AC_SUBST(MPI_GET_SIZE)
-case "X-$MPI_GET_SIZE" in
- X-no)
- AC_MSG_RESULT([no])
- MPI_GET_SIZE=no
- ;;
- X-yes|*)
- AC_MSG_RESULT([yes])
- MPI_GET_SIZE=yes
- AC_DEFINE([HAVE_MPI_GET_SIZE], [1],
- [Define if MPI_File_get_size works correctly])
- ;;
-esac
-
-dnl ----------------------------------------------------------------------
-dnl Check to see whether the complicate MPI derived datatype works.
-dnl In Dec. 20th, 2004, we found that IBM's MPIO implemention didn't
-dnl handle with the displacement of the complicate MPI type derived datatype
-dnl correctly. So we add the check here.
-dnl IBM fixed this bug in their new version that supported MPI-IO around spring 2005.
-dnl We find that mpich 1.2.5 has the similar bug. The same
-dnl bug also occurs at SGI IRIX 6.5 C with compiler version lower than or equal to 7.3.
-dnl In case people still use the old compiler, we keep this flag.
-AC_MSG_CHECKING([if irregular hyperslab optimization code works inside MPI-IO])
-
-AC_CACHE_VAL([hdf5_cv_mpi_complex_derived_datatype_works],[hdf5_cv_mpi_complex_derived_datatype_works=yes])
-
-if test ${hdf5_cv_mpi_complex_derived_datatype_works} = "yes"; then
- AC_DEFINE([MPI_COMPLEX_DERIVED_DATATYPE_WORKS], [1],
- [Define if your system can handle complicated MPI derived datatype correctly.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-
-dnl ----------------------------------------------------------------------
-dnl Check to see whether MPI-IO can do collective IO successfully when one or more processes don't do
-dnl any IOs.
-dnl Up to now(Feb. 8th, 2006), we find that it will cause program hung with mpich 1.2.x version
-dnl and SGI altix. For those systems, we have to turn off this feature and use independent IO instead.
-dnl
-AC_MSG_CHECKING([if MPI-IO can do collective IO when one or more processes don't do IOs])
-
-AC_CACHE_VAL([hdf5_cv_mpi_special_collective_io_works],[hdf5_cv_mpi_special_collective_io_works=yes])
-
-if test ${hdf5_cv_mpi_special_collective_io_works} = "yes"; then
- AC_DEFINE([MPI_SPECIAL_COLLECTIVE_IO_WORKS], [1],
- [Define if your system can handle special collective IO properly.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
+ dnl ----------------------------------------------------------------------
+ dnl Set the flag to indicate that the MPI_File_get_size() function
+ dnl works. The default is enabled unless the user knows the function
+ dnl doesn't work on the system and disables it. (This flag should be set
+ dnl for all machines except for SGI Altix Propack 4 where the function
+ dnl doesn't return correct file size.)
+ dnl
+ AC_ARG_ENABLE([mpi-size],
+ [AC_HELP_STRING([--enable-mpi-size],
+ [Some systems (only SGI Altix Propack 4 so far) return wrong value
+ from MPI_File_get_size. By disabling this function, the library
+ will replace it with stat to get the correct file size.
+ [default=yes]])],
+ [MPI_GET_SIZE=$enableval])
+
+ AC_MSG_CHECKING([if MPI_File_get_size is enabled])
+
+ AC_SUBST(MPI_GET_SIZE)
+ case "X-$MPI_GET_SIZE" in
+ X-no)
+ AC_MSG_RESULT([no])
+ MPI_GET_SIZE=no
+ ;;
+ X-yes|*)
+ AC_MSG_RESULT([yes])
+ MPI_GET_SIZE=yes
+ AC_DEFINE([HAVE_MPI_GET_SIZE], [1],
+ [Define if MPI_File_get_size works correctly])
+ ;;
+ esac
fi
dnl ----------------------------------------------------------------------