summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2004-12-29 14:26:20 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2004-12-29 14:26:20 (GMT)
commit427ff7da2848042f68ecfadf5a321b1d8077e9db (patch)
tree73024b1954031fbb724c2d96a485590348e5cc22 /configure.in
parent9b96fd2003ae74cca389cc4c2216b4371d6eb173 (diff)
downloadhdf5-427ff7da2848042f68ecfadf5a321b1d8077e9db.zip
hdf5-427ff7da2848042f68ecfadf5a321b1d8077e9db.tar.gz
hdf5-427ff7da2848042f68ecfadf5a321b1d8077e9db.tar.bz2
[svn-r9727] Purpose:
Bug Fix/Code Cleanup/Doc Cleanup/Optimization/Branch Sync :-) Description: Generally speaking, this is the "signed->unsigned" change to selections. However, in the process of merging code back, things got stickier and stickier until I ended up doing a big "sync the two branches up" operation. So... I brought back all the "infrastructure" fixes from the development branch to the release branch (which I think were actually making some improvement in performance) as well as fixed several bugs which had been fixed in one branch, but not the other. I've also tagged the repository before making this checkin with the label "before_signed_unsigned_changes". Platforms tested: FreeBSD 4.10 (sleipnir) w/parallel & fphdf5 FreeBSD 4.10 (sleipnir) w/threadsafe FreeBSD 4.10 (sleipnir) w/backward compatibility Solaris 2.7 (arabica) w/"purify options" Solaris 2.8 (sol) w/FORTRAN & C++ AIX 5.x (copper) w/parallel & FORTRAN IRIX64 6.5 (modi4) w/FORTRAN Linux 2.4 (heping) w/FORTRAN & C++ Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 13 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 4806e6e..93354db 100644
--- a/configure.in
+++ b/configure.in
@@ -228,10 +228,6 @@ dnl Check for programs.
dnl
AC_PROG_CC
CC_BASENAME="`echo $CC | cut -f1 -d' ' | xargs basename 2>/dev/null`"
-AC_PROG_MAKE_SET
-AC_PROG_INSTALL
-AC_LIBTOOL_DLOPEN
-AC_PROG_LIBTOOL
dnl ----------------------------------------------------------------------
dnl Check if they would like the Fortran interface compiled
@@ -436,6 +432,11 @@ dnl Export the AR macro so that it will be placed in the libtool file
dnl correctly.
export AR
+AC_PROG_MAKE_SET
+AC_PROG_INSTALL
+AC_LIBTOOL_DLOPEN
+AC_PROG_LIBTOOL
+
dnl Post processing to patch up some deficiencies in libtool
case $host_os in
linux*)
@@ -1761,7 +1762,7 @@ AC_CACHE_VAL([hdf5_cv_printf_ll],
LD_LIBRARY_PATH="$LD_LIBRARY_PATH`echo $LDFLAGS | sed -e 's/-L/:/g' -e 's/ //g'`"
export LD_LIBRARY_PATH
-for hdf5_cv_printf_ll in l L ll q unknown; do
+for hdf5_cv_printf_ll in l ll L q unknown; do
AC_TRY_RUN([
#include <stdio.h>
#include <stdlib.h>
@@ -2824,18 +2825,17 @@ AC_SUBST(HL) HL=""
AC_SUBST(HL_FOR) HL_FOR=""
AC_MSG_CHECKING([if high level library is enabled])
AC_ARG_ENABLE([hl],
- [AC_HELP_STRING([--enable-hl],
- [Enable the high level library [default=yes]])],
- [HDF5_HL=$enableval],
- [HDF5_HL=yes])
-
+ [AC_HELP_STRING([--enable-hl],
+ [Enable the high level library [default=yes]])],
+ [HDF5_HL=$enableval],
+ [HDF5_HL=yes])
+
if test "X$HDF5_HL" = "Xyes"; then
echo "yes"
HL="hl"
else
echo "no"
fi
-
dnl ----------------------------------------------------------------------
dnl Build the Makefiles. Almost every Makefile.in will begin with the line
@@ -2935,8 +2935,6 @@ if test "X$HDF5_HL" = "Xyes" && test "X$HDF_FORTRAN" = "Xyes"; then
# name of folder inside "hl"
HL_FOR="fortran"
fi
-
-
AC_CONFIG_FILES([src/libhdf5.settings
config/depend1
@@ -2957,6 +2955,8 @@ AC_CONFIG_FILES([src/libhdf5.settings
tools/h5dump/testh5dump.sh
tools/h5import/Makefile
tools/h5diff/Makefile
+ tools/h5jam/Makefile
+ tools/h5jam/testh5jam.sh
tools/h5repack/Makefile
tools/h5repack/h5repack.sh
tools/h5ls/Makefile
@@ -2964,8 +2964,6 @@ AC_CONFIG_FILES([src/libhdf5.settings
tools/misc/Makefile
tools/misc/h5cc
tools/gifconv/Makefile
- tools/h5jam/Makefile
- tools/h5jam/testh5jam.sh
examples/Makefile
doc/Makefile
doc/html/Makefile