summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2009-06-09 17:56:22 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2009-06-09 17:56:22 (GMT)
commit5493f48ccb5c70fe765f95f0bccdb4c07338bc76 (patch)
tree6c2c9bb60d3aa79f013ed46765ed66fd815b143d /configure.in
parent4fa1b3c1aa6ee23977c095ceaab7aca4ce2b9edf (diff)
downloadhdf5-5493f48ccb5c70fe765f95f0bccdb4c07338bc76.zip
hdf5-5493f48ccb5c70fe765f95f0bccdb4c07338bc76.tar.gz
hdf5-5493f48ccb5c70fe765f95f0bccdb4c07338bc76.tar.bz2
[svn-r17019] Description:
Break out the configure check for fseeko & ftello from lseek64/fseek64/ ftruncate64, since the check for the latter routines is not a valid check for the former routines. Tested on: FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (smirom) w/Intel compilers w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, in production mode Linux/64-ia64 2.6 (cobalt) w/Intel compilers, w/C++ & FORTRAN, in production mode Linux/64-ia64 2.4 (tg-login3) w/parallel, w/FORTRAN, in debug mode Linux/64-amd64 2.6 (abe) w/parallel, w/FORTRAN, in production mode Mac OS X/32 10.5.7 (amazon) in debug mode Mac OS X/32 10.5.7 (amazon) w/C++ & FORTRAN, w/threadsafe, in production mode
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 29f7eef..283c3fd 100644
--- a/configure.in
+++ b/configure.in
@@ -1287,8 +1287,9 @@ esac
AC_TRY_COMPILE([#include <sys/types.h>],
[off64_t n = 0;],
- [AC_CHECK_FUNCS([lseek64 fseek64 ftruncate64 fseeko ftello])],
- [AC_MSG_RESULT([skipping test for lseek64(), fseek64(), ftruncate64(), fseeko(), and ftello()])])
+ [AC_CHECK_FUNCS([lseek64 fseek64 ftruncate64])],
+ [AC_MSG_RESULT([skipping test for lseek64(), fseek64(), ftruncate64()])])
+AC_CHECK_FUNCS(fseeko ftello)
AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/stat.h>],