summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2006-05-14 05:09:25 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2006-05-14 05:09:25 (GMT)
commit84b03a51c7104f2b691c7067d0d82b28880b9086 (patch)
tree3a68086ed4a0d90232708c2214f5c1fa55fe775d /configure.in
parent0742585e9aaacf513a5ab44da5e4755c9c0c5d60 (diff)
downloadhdf5-84b03a51c7104f2b691c7067d0d82b28880b9086.zip
hdf5-84b03a51c7104f2b691c7067d0d82b28880b9086.tar.gz
hdf5-84b03a51c7104f2b691c7067d0d82b28880b9086.tar.bz2
[svn-r12348] Purpose:
Bug fix. Description: Some machines (e.g., HPUX) will have off64_t defined but no support for stat64 unless certain LargeFile macro is turned on. This caused the last fix on H5private not quite right which caused compiling failures. Solution: Added stat64 and fstat64 tests and then will use them only if they are supported. Platforms tested: Tested on kelgia, copper and heping (pll). (Compiling alright but tests for kelgia and heping are not done. expect no problems.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 32e316a..54800fb 100644
--- a/configure.in
+++ b/configure.in
@@ -942,6 +942,12 @@ AC_TRY_COMPILE([#include <sys/types.h>],
[off64_t n = 0;],
[AC_CHECK_FUNCS([lseek64 fseek64])],
[AC_MSG_RESULT([skipping test for lseek64() and fseek64()])])
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/stat.h>],
+[struct stat64 sb;],
+[AC_CHECK_FUNCS([stat64 fstat64])],
+[AC_MSG_RESULT([skipping test for stat64() and fstat64()])])
dnl ----------------------------------------------------------------------
dnl Data types and their sizes.