summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2009-11-23 21:34:51 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2009-11-23 21:34:51 (GMT)
commitb7e35aef0e7f4e378e98c18f2c787bd9eaa8a0cd (patch)
tree5630386db4f001c29823ed59dbca3c282b36be75 /configure.in
parent0ced243b9a4915950f7108c3acad43485fd1e609 (diff)
downloadhdf5-b7e35aef0e7f4e378e98c18f2c787bd9eaa8a0cd.zip
hdf5-b7e35aef0e7f4e378e98c18f2c787bd9eaa8a0cd.tar.gz
hdf5-b7e35aef0e7f4e378e98c18f2c787bd9eaa8a0cd.tar.bz2
[svn-r17924] Description:
Add detection for POSIX lstat() routine to configure script (mostly for non-UNIX/Linux machines) and add macro wrapper for it. Alphabetatize the system/library calls we test for, to make them easier to read. Removed the sigaction() detection & macro wrappers, since it's not used by the distribution currently. Tested on: FreeBSD/32 6.3 (duty) in debug mode FreeBSD/64 6.3 (liberty) w/C++ & FORTRAN, in debug mode Linux/32 2.6 (jam) w/PGI compilers, w/default API=1.8.x, w/C++ & FORTRAN, w/threadsafe, in debug mode Linux/64-amd64 2.6 (smirom) w/Intel compilers, w/default API=1.6.x, w/C++ & FORTRAN, in production mode Solaris/32 2.10 (linew) w/deprecated symbols disabled, w/C++ & FORTRAN, w/szip filter, in production mode Linux/64-ia64 2.6 (cobalt) w/Intel compilers, w/C++ & FORTRAN, in production mode Linux/64-ia64 2.4 (tg-login3) w/parallel, w/FORTRAN, in debug mode Linux/64-amd64 2.6 (abe) w/parallel, w/FORTRAN, in production mode Mac OS X/32 10.6.2 (amazon) in debug mode Mac OS X/32 10.6.2 (amazon) w/C++ & FORTRAN, w/threadsafe, in production mode
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 28f919d..0d4963b 100644
--- a/configure.in
+++ b/configure.in
@@ -1974,13 +1974,11 @@ AC_MSG_RESULT([no]))
dnl ----------------------------------------------------------------------
dnl Check for functions.
-dnl tmpfile needed by h5pdiff.
dnl
-AC_CHECK_FUNCS(alarm fork frexpf frexpl gethostname getpwuid getrusage)
-AC_CHECK_FUNCS(BSDgettimeofday siglongjmp longjmp setsysinfo sigaction)
-AC_CHECK_FUNCS(signal snprintf vasprintf strdup system waitpid)
-AC_CHECK_FUNCS(rand_r random srandom)
-AC_CHECK_FUNCS(tmpfile)
+AC_CHECK_FUNCS(alarm BSDgettimeofday fork frexpf frexpl)
+AC_CHECK_FUNCS(gethostname getpwuid getrusage longjmp lstat)
+AC_CHECK_FUNCS(rand_r random setsysinfo siglongjmp signal)
+AC_CHECK_FUNCS(snprintf srandom strdup system tmpfile vasprintf waitpid)
dnl Check for vsnprintf() separately, so we can detect situations where it
dnl doesn't return the correct size for formatted strings that are too large