summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2004-10-12 20:49:28 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2004-10-12 20:49:28 (GMT)
commitd86b3c0205888c195d3f57d6d1fed97749a2d7a1 (patch)
tree27466c86317ede6feda3fe232e8e73cf360c70a8 /configure.in
parent86d0132279cdcb7bc9b793e94509b0abd5b3147e (diff)
downloadhdf5-d86b3c0205888c195d3f57d6d1fed97749a2d7a1.zip
hdf5-d86b3c0205888c195d3f57d6d1fed97749a2d7a1.tar.gz
hdf5-d86b3c0205888c195d3f57d6d1fed97749a2d7a1.tar.bz2
[svn-r9410] Purpose:
Code cleanup Description: Update FORTRAN configuration test code to be more syntacticly correct and not generate errors with stricter standards checking in the compiler. Platforms tested: Linux 2.4 (verbena) Too minor to require h5committest
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 069ec54..de8ae57 100644
--- a/configure.in
+++ b/configure.in
@@ -2211,18 +2211,22 @@ case "X-$enable_parallel" in
dnl Try link a simple MPI program. If fail, try again with -lmpi.
AC_TRY_FLINK(mpif.h, [
+ integer:: ierr
call mpi_file_open( ierr )],,
AC_CHECK_FLIB(mpi, [
include 'mpif.h'
+ integer:: ierr
call mpi_file_open( ierr )],, PARALLEL=no))
dnl Then try link a simple MPI-IO program. If fail, try again with
dnl -lmpio.
if test "X$PARALLEL" = "Xyes"; then
AC_TRY_FLINK(mpif.h, [
+ integer:: ierr
call mpi_file_open( ierr )],,
AC_CHECK_FLIB(mpio, [
include 'mpif.h'
+ integer:: ierr
call mpi_file_open( ierr )],, PARALLEL=no))
fi