summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPedro Vicente Nunes <pvn@hdfgroup.org>2004-12-08 20:31:25 (GMT)
committerPedro Vicente Nunes <pvn@hdfgroup.org>2004-12-08 20:31:25 (GMT)
commitdd7c7944690a1d9958069b925231c7cd6623857c (patch)
tree03f76e4cded94faa8fc170feccc636047c3b305a /configure.in
parent38eedcb94c85404ef82b53cd1ffdacfacbcef14c (diff)
downloadhdf5-dd7c7944690a1d9958069b925231c7cd6623857c.zip
hdf5-dd7c7944690a1d9958069b925231c7cd6623857c.tar.gz
hdf5-dd7c7944690a1d9958069b925231c7cd6623857c.tar.bz2
[svn-r9644] Purpose:
add hl fortran Description: Solution: Platforms tested: linux (absfot and pgf90) solaris (32 and 64 bit) AIX note : HP gives a compiling error , to be fixed in the future Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4e096e9..41ba4cb 100644
--- a/configure.in
+++ b/configure.in
@@ -2820,6 +2820,8 @@ dnl Check if they would like the High Level library compiled
dnl
AC_SUBST(HL) HL=""
+# name of fortran folder inside "hl", if FORTRAN compile is requested
+AC_SUBST(HL_FOR) HL_FOR=""
AC_MSG_CHECKING([if high level library is enabled])
AC_ARG_ENABLE([hl],
[AC_HELP_STRING([--enable-hl],
@@ -2916,14 +2918,24 @@ if test "X$HDF_CXX" = "Xyes"; then
fi
# conditionally generate the high level makefiles
-# to do : fortran with hl
-
if test "X$HDF5_HL" = "Xyes"; then
HL_FILES="hl/Makefile
hl/src/Makefile
hl/test/Makefile"
fi
+# with FORTRAN support
+if test "X$HDF5_HL" = "Xyes" && test "X$HDF_FORTRAN" = "Xyes"; then
+ HL_FILES="hl/Makefile
+ hl/src/Makefile
+ hl/test/Makefile
+ hl/fortran/Makefile
+ hl/fortran/src/Makefile
+ hl/fortran/test/Makefile"
+# name of folder inside "hl"
+HL_FOR="fortran"
+fi
+
AC_CONFIG_FILES([src/libhdf5.settings