summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-13 21:55:21 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-13 21:55:21 (GMT)
commit4463d9b84c08cabe2033edd44d407eeab780fb82 (patch)
tree9b045e51e322ef410db600ecb2e4e095665c984b /configure.in
parent93bea90f586a30e334ae8191a1413d906c76ddde (diff)
downloadhdf5-4463d9b84c08cabe2033edd44d407eeab780fb82.zip
hdf5-4463d9b84c08cabe2033edd44d407eeab780fb82.tar.gz
hdf5-4463d9b84c08cabe2033edd44d407eeab780fb82.tar.bz2
[svn-r17639] Purpose:
Configure Fix Description: uP (AIX Machine) was failing because configure needs to see -k flag in FCFLAGS for some checks to behave as intended. Since the config files were switched to passing all flags into H5_FCCFLAGS, this broke this behavior. To allow configure to see this again, FCFLAGS and all other user flags are saved before doing anything, and restored at the end of configure, so if needed we can set these values in configure and/or the config/ files without (permanently) overriding or changing anything a user sets. Also modified the powerpc-ibm-aix5.x config file to once again put -k into FCFLAGS in addition to H5_FCFLAGS (the former of which will be restored after configure completes the checks). Tested: h5committest (jam and amani finished, linew still running, though I wanted to get this in for daily tests since it needs to be run on uP for final verification).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5d507d9..c9d8e3f 100644
--- a/configure.in
+++ b/configure.in
@@ -114,9 +114,12 @@ FCFLAGS="${FCFLAGS}"
CPPFLAGS="${CPPFLAGS}"
LDFLAGS="${LDFLAGS}"
-dnl Configure will need to alter LDFLAGS and CPPFLAGS in order for
+dnl Configure may need to alter any of the *FLAGS variables in order for
dnl various checks to work correctly. Save the user's value here so it
dnl can be restored once all configure checks are complete.
+saved_user_CFLAGS="$CFLAGS"
+saved_user_CXXFLAGS="$CXXFLAGS"
+saved_user_FCFLAGS="$FCFLAGS"
saved_user_LDFLAGS="$LDFLAGS"
saved_user_CPPFLAGS="$CPPFLAGS"
@@ -3991,6 +3994,9 @@ dnl ------------------------------------
dnl Restore user's CPPFLAGS and LDFLAGS.
CPPFLAGS="$saved_user_CPPFLAGS"
LDFLAGS="$saved_user_LDFLAGS"
+FCFLAGS="$saved_user_FCFLAGS"
+CFLAGS="$saved_user_CFLAGS"
+CXXFLAGS="$saved_user_CXXFLAGS"
dnl ----------------------------------------------------------------------