summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1998-02-03 17:03:13 (GMT)
committerRobb Matzke <matzke@llnl.gov>1998-02-03 17:03:13 (GMT)
commit137bc83f7a8f1f552b53a97d21d89269c844a051 (patch)
tree202ed34e5641d70c810a3f53e09d65b913b25402 /configure.in
parent6cbd6722513cede31afd1826cb842b947ae8b996 (diff)
downloadhdf5-137bc83f7a8f1f552b53a97d21d89269c844a051.zip
hdf5-137bc83f7a8f1f552b53a97d21d89269c844a051.tar.gz
hdf5-137bc83f7a8f1f552b53a97d21d89269c844a051.tar.bz2
[svn-r213] Changes since 19980130
---------------------- ./MANIFEST Added H5Fmpio.c. One way to check that you've properly included new files is to run `./bin/release none', then unpack the resulting tar file somewhere and try to compile it. The tar file will be ./releases/hdf-5.0.0a.tar. ./config/freebsd2.2.1 ./config/linux Added `-ansi' ./acconfig.h Added definitions for PHDF5 and HAVE_PARALLEL. ./configure.in Added minimal support for parallel build. Kim and Albert will have to flesh this out or I can do it if they're more specific about what they need. ./config/commence.in Added default value for $(RUNTEST) ./config/conclude.in `make test' uses value of $(RUNTEST) to run test cases. ./src/Makefile.in Added PARALLEL_SRC for conditional compilation of H5Fmpio.c ./src/H5D.c ./src/H5Dpublic.h Added H5Dget_type() for Elena NOTE: These changes require that configure be rerun. If you're using GNU make it will happen automatically, otherwise do it by hand.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8680e93..36951cb 100644
--- a/configure.in
+++ b/configure.in
@@ -124,6 +124,46 @@ AC_TRY_COMPILE(,[int f(void){return __FUNCTION__;}],
AC_MSG_RESULT(no))
+dnl ----------------------------------------------------------------------
+dnl Check for parallel support
+dnl
+AC_ARG_ENABLE(parallel,
+ --enable-parallel=mpio Enable parallel support with MPIO,
+ PARALLEL=$enableval)
+AC_MSG_CHECKING(for parallel support);
+AC_SUBST(PARALLEL_SRC)
+AC_SUBST(RUNTEST) RUNTEST=""
+
+case "X-$PARALLEL" in
+
+ X-|X-no)
+ # Parallel support is not enabled
+ AC_MSG_RESULT(disabled)
+ ;;
+
+ X-mpio|X-yes)
+ # Use MPIO. Define PHDF5 in src/H5config.h (comes from ./acconfig.h)
+ # and augment the include and library search paths (it doesn't hurt
+ # to have extra paths). Then check for header files and libraries.
+ # Some extra source files are added to the list also so we don't have
+ # to ifdef out the whole file.
+ AC_MSG_RESULT(mpio)
+ AC_DEFINE(PHDF5) dnl THIS WILL GO AWAY SHORTLY!!!
+ AC_DEFINE(HAVE_PARALLEL)
+ PARALLEL_SRC='$(PARALLEL_SRC)'
+ CFLAGS="$CFLAGS -I/foo/bar/parallel/include"
+ CFLAGS="$CFLAGS -L/foo/bar/parallel/lib"
+ AC_CHECK_LIB(mpi,main) dnl Replace `main' with some function
+ AC_CHECK_LIB(mpio,main) dnl Replace `main' with some function
+ RUNTEST=mpirun
+ ;;
+
+ *)
+ AC_MSG_ERROR(unknown parallel support: $PARALLEL)
+ ;;
+esac
+
+
dnl ----------------------------------------------------------------------
dnl Build the Makefiles. Almost every Makefile.in will begin with the line