summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1998-07-08 18:41:04 (GMT)
committerRobb Matzke <matzke@llnl.gov>1998-07-08 18:41:04 (GMT)
commit768b7465a19afcbc87ba54a7b6400492d54c2626 (patch)
tree67d1e32adcfdbf0905189ff3ca1d60c2c40a6b1a /configure.in
parent1ce18a997166808519476b505f5bb0c4f34e1ea0 (diff)
downloadhdf5-768b7465a19afcbc87ba54a7b6400492d54c2626.zip
hdf5-768b7465a19afcbc87ba54a7b6400492d54c2626.tar.gz
hdf5-768b7465a19afcbc87ba54a7b6400492d54c2626.tar.bz2
[svn-r471] Changes since 19980708
---------------------- ./MANIFEST Alphabetized. `d' comes before `e' :-) ./bin/release Added the `-batch' option which causes the script to not ask questions and to automatically update the minor version number and set the patch level back to `a'. This is intended to be used for the daily snapshots: #! /bin/sh set -e cd ~/hdf5 make distclean make test bin/release -batch tar compress gzip bzip2 mv ./releases/* /repository ./src/H5Z.c Removed warnings about unused variables when the zlib.h header file is present but libz.a isn't. ./INSTALL ./configure.in ./doc/html/tracing.html Made API tracing the default (you still need to define the HDF5_TRACE environment variable to get results) and change the name from `--disable-tracing' to `--disable-trace' to make it consistent with the other switches. Changed `site config file' to `host config file' to match the documentation. ./doc/html/H5.user.html Added a reference to the `tracing.html' file.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 17 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index e3a4f5c..d5dccc3 100644
--- a/configure.in
+++ b/configure.in
@@ -44,8 +44,8 @@ dnl OS
dnl VENDOR
dnl CPU
dnl
-AC_MSG_CHECKING(for site config file)
-site_config="none"
+AC_MSG_CHECKING(for host config file)
+host_config="none"
for f in $host \
$host_vendor-$host_os \
$host_cpu-$host_os \
@@ -54,13 +54,13 @@ for f in $host \
$host_vendor \
$host_cpu ; do
if test -f config/$f; then
- site_config=config/$f
+ host_config=config/$f
break
fi
done
-AC_MSG_RESULT($site_config)
-if test $site_config != "none"; then
- . $site_config
+AC_MSG_RESULT($host_config)
+if test $host_config != "none"; then
+ . $host_config
fi
@@ -265,12 +265,17 @@ dnl ----------------------------------------------------------------------
dnl Enable tracing of the API
dnl
AC_MSG_CHECKING(for API tracing);
-AC_ARG_ENABLE(tracing,
- --enable-tracing Cause the library to trace all API calls,
- CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
- AC_MSG_RESULT(yes),
- CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
- AC_MSG_RESULT(no))
+AC_ARG_ENABLE(trace,
+ [--disable-trace Disable API tracing capability],
+ TRACE=$enableval)
+
+if test X = "X$TRACE" -o Xyes = "X$TRACE"; then
+ AC_MSG_RESULT(yes)
+ CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
+else
+ AC_MSG_RESULT(no)
+ CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
+fi
dnl ----------------------------------------------------------------------
dnl Check for parallel support