summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2024-01-03 20:17:46 (GMT)
committerGitHub <noreply@github.com>2024-01-03 20:17:46 (GMT)
commit772276ea1f6f8b150a22eff3a908eff24ccc50a7 (patch)
tree29d4f2850422dccf3b4e057786f9766b8e2adc54 /examples/CMakeLists.txt
parent8f1a93f1a208055c9b872a06be28a20e72f8f488 (diff)
downloadhdf5-772276ea1f6f8b150a22eff3a908eff24ccc50a7.zip
hdf5-772276ea1f6f8b150a22eff3a908eff24ccc50a7.tar.gz
hdf5-772276ea1f6f8b150a22eff3a908eff24ccc50a7.tar.bz2
Remove examples that have been moved to HDF5Examples folder (#3917)
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 10c6ede..43d7af2 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -32,28 +32,8 @@ set (examples
h5_elink_unix2win
h5_shared_mesg
h5_debug_trace
- h5_vds
- h5_vds-exc
- h5_vds-exclim
- h5_vds-eiger
- h5_vds-simpleIO
- h5_vds-percival
- h5_vds-percival-unlim
- h5_vds-percival-unlim-maxmin
)
-if (H5_HAVE_PARALLEL)
- set (parallel_examples
- ph5example
- ph5_filtered_writes
- ph5_filtered_writes_no_sel
- )
-
- if (HDF5_ENABLE_SUBFILING_VFD)
- list (APPEND parallel_examples ph5_subfiling)
- endif ()
-endif ()
-
foreach (example ${examples})
add_executable (${example} ${HDF5_EXAMPLES_SOURCE_DIR}/${example}.c)
target_include_directories (${example} PRIVATE "${HDF5_SRC_INCLUDE_DIRS};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
@@ -74,28 +54,6 @@ foreach (example ${examples})
endif ()
endforeach ()
-if (H5_HAVE_PARALLEL)
- foreach (parallel_example ${parallel_examples})
- add_executable (${parallel_example} ${HDF5_EXAMPLES_SOURCE_DIR}/${parallel_example}.c)
- target_include_directories (${parallel_example} PRIVATE "${HDF5_SRC_INCLUDE_DIRS};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
- if (NOT BUILD_SHARED_LIBS)
- TARGET_C_PROPERTIES (${parallel_example} STATIC)
- target_link_libraries (${parallel_example} PRIVATE ${HDF5_LIB_TARGET} MPI::MPI_C)
- else ()
- TARGET_C_PROPERTIES (${parallel_example} SHARED)
- target_link_libraries (${parallel_example} PRIVATE ${HDF5_LIBSH_TARGET} MPI::MPI_C)
- endif ()
- set_target_properties (${parallel_example} PROPERTIES FOLDER examples)
-
- #-----------------------------------------------------------------------------
- # Add Target to clang-format
- #-----------------------------------------------------------------------------
- if (HDF5_ENABLE_FORMATTERS)
- clang_format (HDF5_EXAMPLES_${parallel_example}_FORMAT ${parallel_example})
- endif ()
- endforeach ()
-endif ()
-
if (BUILD_TESTING AND HDF5_TEST_EXAMPLES)
include (CMakeTests.cmake)
endif ()