summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-09-28 15:55:19 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-09-28 15:55:19 (GMT)
commit8ee8b7abb55bc8d901e31b3eef9ba35abb352814 (patch)
treeadd2bf906dec7285d26dbe2e2107ec07d2f685da /examples/CMakeLists.txt
parentaa08db839e6aea89487be985704d57a0e424b21b (diff)
parent088014bef4216eede409d103876a9fd3efadd358 (diff)
downloadhdf5-8ee8b7abb55bc8d901e31b3eef9ba35abb352814.zip
hdf5-8ee8b7abb55bc8d901e31b3eef9ba35abb352814.tar.gz
hdf5-8ee8b7abb55bc8d901e31b3eef9ba35abb352814.tar.bz2
Merge pull request #2902 in HDFFV/hdf5 from ~BYRN/hdf5_adb:develop to develop
* commit '088014bef4216eede409d103876a9fd3efadd358': More info for building plugins with library Remove setting from cacheinit file OESS-98 add release note for option OESS-98 merge with clang-format changes
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index b7e7cf0..9ab870f 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -44,7 +44,7 @@ set (examples
foreach (example ${examples})
add_executable (${example} ${HDF5_EXAMPLES_SOURCE_DIR}/${example}.c)
- target_include_directories (${example} PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
+ target_include_directories (${example} PRIVATE "${HDF5_SRC_DIR};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (${example} STATIC)
target_link_libraries (${example} PRIVATE ${HDF5_LIB_TARGET})
@@ -64,7 +64,7 @@ endforeach ()
if (H5_HAVE_PARALLEL)
add_executable (ph5example ${HDF5_EXAMPLES_SOURCE_DIR}/ph5example.c)
- target_include_directories (ph5example PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
+ target_include_directories (ph5example PRIVATE "${HDF5_SRC_DIR};${HDF5_SRC_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (ph5example STATIC)
target_link_libraries (ph5example PRIVATE ${HDF5_LIB_TARGET} ${MPI_C_LIBRARIES})