summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-13 16:01:50 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-13 16:01:50 (GMT)
commitae06433ab0ca13838c2762c8fad165a041d64c42 (patch)
tree72d645731c00953c3daf6dad8a1cf0dc97326943 /examples/CMakeLists.txt
parent940931aa853602b0b6edfd4ca1a6526fd7975dd2 (diff)
downloadhdf5-ae06433ab0ca13838c2762c8fad165a041d64c42.zip
hdf5-ae06433ab0ca13838c2762c8fad165a041d64c42.tar.gz
hdf5-ae06433ab0ca13838c2762c8fad165a041d64c42.tar.bz2
[svn-r18793] Add files to support building library with CMake
Tested: Local linux
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..fdd3f80
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,35 @@
+cmake_minimum_required (VERSION 2.8)
+PROJECT (HDF5_EXAMPLES)
+
+#-----------------------------------------------------------------------------
+# Define Sources
+#-----------------------------------------------------------------------------
+SET (examples
+ h5_write
+ h5_read
+ h5_extend_write
+ h5_chunk_read
+ h5_compound
+ h5_group
+ h5_select
+ h5_attribute
+ h5_mount
+ h5_reference
+ h5_drivers
+ h5_ref2reg
+ h5_extlink
+ h5_elink_unix2win
+ h5_shared_mesg
+)
+
+FOREACH (example ${examples})
+ ADD_EXECUTABLE (${example} ${HDF5_EXAMPLES_SOURCE_DIR}/${example}.c)
+ H5_NAMING (${example})
+ TARGET_LINK_LIBRARIES (${example} ${HDF5_LIB_TARGET})
+ENDFOREACH (example ${examples})
+
+IF (H5_HAVE_PARALLEL)
+ ADD_EXECUTABLE (ph5example ${HDF5_EXAMPLES_SOURCE_DIR}/ph5example.c)
+ H5_NAMING (ph5example)
+ TARGET_LINK_LIBRARIES (ph5example ${HDF5_LIB_TARGET})
+ENDIF (H5_HAVE_PARALLEL)