summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-03-24 20:22:37 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-03-24 20:22:37 (GMT)
commitf1abdf0e5ef1d1fe0889fafa9cfa64cc7c6bc5c3 (patch)
tree8b93224f27eb27d939793c60947965103f7c5d87 /examples/CMakeLists.txt
parente17033cb40c7268e66b0dcd4409799b1674c77dc (diff)
downloadhdf5-f1abdf0e5ef1d1fe0889fafa9cfa64cc7c6bc5c3.zip
hdf5-f1abdf0e5ef1d1fe0889fafa9cfa64cc7c6bc5c3.tar.gz
hdf5-f1abdf0e5ef1d1fe0889fafa9cfa64cc7c6bc5c3.tar.bz2
[svn-r20324] Correct depends of test for examples and add clear test
Tested:local linux
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt66
1 files changed, 54 insertions, 12 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 87a21881..2bc8aac 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -26,22 +26,64 @@ FOREACH (example ${examples})
ADD_EXECUTABLE (${example} ${HDF5_EXAMPLES_SOURCE_DIR}/${example}.c)
TARGET_NAMING (${example} ${LIB_TYPE})
TARGET_LINK_LIBRARIES (${example} ${HDF5_LIB_TARGET})
-
- IF (BUILD_TESTING)
- ADD_TEST (NAME ${example} COMMAND $<TARGET_FILE:${example}>)
- ENDIF (BUILD_TESTING)
ENDFOREACH (example ${examples})
-IF (BUILD_TESTING)
- FILE (MAKE_DIRECTORY ${PROJECT_BINARY_DIR}/red ${PROJECT_BINARY_DIR}/blue ${PROJECT_BINARY_DIR}/u2w)
-ENDIF (BUILD_TESTING)
-
IF (H5_HAVE_PARALLEL)
ADD_EXECUTABLE (ph5example ${HDF5_EXAMPLES_SOURCE_DIR}/ph5example.c)
TARGET_NAMING (ph5example ${LIB_TYPE})
TARGET_LINK_LIBRARIES (ph5example ${HDF5_LIB_TARGET})
-
- IF (BUILD_TESTING)
- ADD_TEST (NAME ph5example COMMAND $<TARGET_FILE:ph5example>)
- ENDIF (BUILD_TESTING)
ENDIF (H5_HAVE_PARALLEL)
+
+IF (BUILD_TESTING)
+ FILE (MAKE_DIRECTORY ${PROJECT_BINARY_DIR}/red ${PROJECT_BINARY_DIR}/blue ${PROJECT_BINARY_DIR}/u2w)
+
+ # Remove any output file left over from previous test run
+ ADD_TEST (
+ NAME EXAMPLES-clear-objects
+ COMMAND ${CMAKE_COMMAND}
+ -E remove
+ Attributes.h5
+ btrees_file.h5
+ default_file.h5
+ extlink_prefix_source.h5
+ extlink_source.h5
+ extlink_target.h5
+ group.h5
+ hard_link.h5
+ mount1.h5
+ mount2.h5
+ one_index_file.h5
+ only_dspaces_and_attrs_file.h5
+ only_huge_mesgs_file.h5
+ REF_REG.h5
+ refere.h5
+ SDS.h5
+ SDScompound.h5
+ SDSextendible.h5
+ Select.h5
+ separate_indexes_file.h5
+ small_lists_file.h5
+ soft_link.h5
+ unix2win.h5
+ )
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (EXAMPLES-clear-objects PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
+ SET (last_test "EXAMPLES-clear-objects")
+
+ FOREACH (example ${examples})
+ ADD_TEST (NAME EXAMPLES-${example} COMMAND $<TARGET_FILE:${example}>)
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (EXAMPLES-${example} PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
+ SET (last_test "EXAMPLES-${example}")
+ ENDFOREACH (example ${examples})
+
+ IF (H5_HAVE_PARALLEL)
+ ADD_TEST (NAME EXAMPLES-ph5example COMMAND $<TARGET_FILE:ph5example>)
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (EXAMPLES-ph5example PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
+ SET (last_test "EXAMPLES-ph5example")
+ ENDIF (H5_HAVE_PARALLEL)
+ENDIF (BUILD_TESTING)