summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2015-04-03 21:41:28 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2015-04-03 21:41:28 (GMT)
commit5630846ea34f29b45aecdb431f846327c4fde9e1 (patch)
tree83e65a0feb757f39472e70d2168048d091cfed50 /examples/CMakeLists.txt
parent820b4dc39136072bccad1455fc0232ec9e710d58 (diff)
parentb9e5e2af4e31b0a60c2d2f6421fb1b3cb9aa0564 (diff)
downloadhdf5-5630846ea34f29b45aecdb431f846327c4fde9e1.zip
hdf5-5630846ea34f29b45aecdb431f846327c4fde9e1.tar.gz
hdf5-5630846ea34f29b45aecdb431f846327c4fde9e1.tar.bz2
[svn-r26724] - merge from trunk & fix conflicts.
- fix bug in opending an already open named datatype. - fix dynamically loaded VOL plugin support with new changes coming in.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 318417d..f0370cf 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required (VERSION 2.8.11)
+cmake_minimum_required (VERSION 3.1.0)
PROJECT (HDF5_EXAMPLES)
#-----------------------------------------------------------------------------
@@ -40,7 +40,7 @@ set (examples
foreach (example ${examples})
add_executable (${example} ${HDF5_EXAMPLES_SOURCE_DIR}/${example}.c)
TARGET_NAMING (${example} ${LIB_TYPE})
- TARGET_C_PROPERTIES (${example} " " " ")
+ TARGET_C_PROPERTIES (${example} ${LIB_TYPE} " " " ")
target_link_libraries (${example} ${HDF5_LIB_TARGET})
set_target_properties (${example} PROPERTIES FOLDER examples)
endforeach (example ${examples})
@@ -48,7 +48,7 @@ endforeach (example ${examples})
if (H5_HAVE_PARALLEL)
add_executable (ph5example ${HDF5_EXAMPLES_SOURCE_DIR}/ph5example.c)
TARGET_NAMING (ph5example ${LIB_TYPE})
- TARGET_C_PROPERTIES (ph5example " " " ")
+ TARGET_C_PROPERTIES (ph5example ${LIB_TYPE} " " " ")
target_link_libraries (ph5example ${HDF5_LIB_TARGET})
set_target_properties (ph5example PROPERTIES FOLDER examples)
endif (H5_HAVE_PARALLEL)