summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2013-08-21 15:44:35 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2013-08-21 15:44:35 (GMT)
commit78d8f8d7d12e779f640cf037bc52fd7e8a07061c (patch)
treef6a2bb20a4a34804b0253c18c205c5f77103d843 /examples/CMakeLists.txt
parentff14409081fe6a5826b25658577aaf59f8fbb78f (diff)
parent482a9c28e71b0c1b3767bcf30be3c534bbc65ed9 (diff)
downloadhdf5-78d8f8d7d12e779f640cf037bc52fd7e8a07061c.zip
hdf5-78d8f8d7d12e779f640cf037bc52fd7e8a07061c.tar.gz
hdf5-78d8f8d7d12e779f640cf037bc52fd7e8a07061c.tar.bz2
[svn-r24044] Merging r23833 through r24043 from trunk.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt57
1 files changed, 1 insertions, 56 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 60752ec..84545b6 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -54,60 +54,5 @@ IF (H5_HAVE_PARALLEL)
ENDIF (H5_HAVE_PARALLEL)
IF (BUILD_TESTING)
- FILE (MAKE_DIRECTORY ${PROJECT_BINARY_DIR}/red ${PROJECT_BINARY_DIR}/blue ${PROJECT_BINARY_DIR}/u2w)
-
- # Remove any output file left over from previous test run
- ADD_TEST (
- NAME EXAMPLES-clear-objects
- COMMAND ${CMAKE_COMMAND}
- -E remove
- Attributes.h5
- btrees_file.h5
- cmprss.h5
- default_file.h5
- dset.h5
- extend.h5
- extlink_prefix_source.h5
- extlink_source.h5
- extlink_target.h5
- group.h5
- groups.h5
- hard_link.h5
- mount1.h5
- mount2.h5
- one_index_file.h5
- only_dspaces_and_attrs_file.h5
- only_huge_mesgs_file.h5
- REF_REG.h5
- refere.h5
- SDS.h5
- SDScompound.h5
- SDSextendible.h5
- Select.h5
- separate_indexes_file.h5
- small_lists_file.h5
- soft_link.h5
- subset.h5
- unix2win.h5
- )
- IF (NOT "${last_test}" STREQUAL "")
- SET_TESTS_PROPERTIES (EXAMPLES-clear-objects PROPERTIES DEPENDS ${last_test})
- ENDIF (NOT "${last_test}" STREQUAL "")
- SET (last_test "EXAMPLES-clear-objects")
-
- FOREACH (example ${examples})
- ADD_TEST (NAME EXAMPLES-${example} COMMAND $<TARGET_FILE:${example}>)
- IF (NOT "${last_test}" STREQUAL "")
- SET_TESTS_PROPERTIES (EXAMPLES-${example} PROPERTIES DEPENDS ${last_test})
- ENDIF (NOT "${last_test}" STREQUAL "")
- SET (last_test "EXAMPLES-${example}")
- ENDFOREACH (example ${examples})
-
- IF (H5_HAVE_PARALLEL)
- ADD_TEST (NAME EXAMPLES-ph5example COMMAND $<TARGET_FILE:ph5example>)
- IF (NOT "${last_test}" STREQUAL "")
- SET_TESTS_PROPERTIES (EXAMPLES-ph5example PROPERTIES DEPENDS ${last_test})
- ENDIF (NOT "${last_test}" STREQUAL "")
- SET (last_test "EXAMPLES-ph5example")
- ENDIF (H5_HAVE_PARALLEL)
+ INCLUDE (CMakeTests.cmake)
ENDIF (BUILD_TESTING)