summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-03-20 21:17:24 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-03-20 21:17:24 (GMT)
commitba2c98d42aded8887e27f4621afbdb63eb8cedf6 (patch)
treee6f50069e99d3a7f5f721986655a7dbf88bf7b51 /examples/CMakeLists.txt
parent0be0491ee4d7fd793cc3d4426aa94268d186a47a (diff)
downloadhdf5-ba2c98d42aded8887e27f4621afbdb63eb8cedf6.zip
hdf5-ba2c98d42aded8887e27f4621afbdb63eb8cedf6.tar.gz
hdf5-ba2c98d42aded8887e27f4621afbdb63eb8cedf6.tar.bz2
[svn-r24850] example causes modal permission dialog to popup on windows. Do not build.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index fe8216d..38aa241 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -44,13 +44,14 @@ foreach (example ${examples})
set_target_properties (${example} PROPERTIES FOLDER examples)
endforeach (example ${examples})
-if (H5_HAVE_PARALLEL)
+### Windows pops up a modal permission dialog on this test
+if (H5_HAVE_PARALLEL AND NOT WIN32)
add_executable (ph5example ${HDF5_EXAMPLES_SOURCE_DIR}/ph5example.c)
TARGET_NAMING (ph5example ${LIB_TYPE})
TARGET_C_PROPERTIES (ph5example " " " ")
target_link_libraries (ph5example ${HDF5_LIB_TARGET})
set_target_properties (ph5example PROPERTIES FOLDER examples)
-endif (H5_HAVE_PARALLEL)
+endif (H5_HAVE_PARALLEL AND NOT WIN32)
if (BUILD_TESTING)
include (CMakeTests.cmake)