summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-06-10 17:46:48 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-06-10 17:46:48 (GMT)
commitfeb14ea872ed5889de014e35c421b37501fbe38a (patch)
tree28a7eb1eb0961fb3db0f67306fb0efd1cc550258 /examples/CMakeLists.txt
parent001f6a53bff1ff0a074e52a31ee9ce3e61a0e7ce (diff)
downloadhdf5-feb14ea872ed5889de014e35c421b37501fbe38a.zip
hdf5-feb14ea872ed5889de014e35c421b37501fbe38a.tar.gz
hdf5-feb14ea872ed5889de014e35c421b37501fbe38a.tar.bz2
[svn-r23745] HDFFV-8461: Add Windows /MT support
This adds the UserMacros.cmake support needed.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 3abf97a..01daf69 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -39,6 +39,7 @@ SET (examples
FOREACH (example ${examples})
ADD_EXECUTABLE (${example} ${HDF5_EXAMPLES_SOURCE_DIR}/${example}.c)
TARGET_NAMING (${example} ${LIB_TYPE})
+ TARGET_C_PROPERTIES (${example} " " " ")
TARGET_LINK_LIBRARIES (${example} ${HDF5_LIB_TARGET})
SET_TARGET_PROPERTIES (${example} PROPERTIES FOLDER examples)
ENDFOREACH (example ${examples})
@@ -46,6 +47,7 @@ ENDFOREACH (example ${examples})
IF (H5_HAVE_PARALLEL)
ADD_EXECUTABLE (ph5example ${HDF5_EXAMPLES_SOURCE_DIR}/ph5example.c)
TARGET_NAMING (ph5example ${LIB_TYPE})
+ TARGET_C_PROPERTIES (ph5example " " " ")
TARGET_LINK_LIBRARIES (ph5example ${HDF5_LIB_TARGET})
SET_TARGET_PROPERTIES (ph5example PROPERTIES FOLDER examples)
ENDIF (H5_HAVE_PARALLEL)