summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-01 22:22:55 (GMT)
commitc63ef2cba28df827eb090a019284c7cd8c2982af (patch)
tree134ff7254d8ee7b1c6f7fa3eabc509528899d68d /examples/Makefile.am
parentf2240792704b74fc288b4e4a570509c4afe4a34e (diff)
downloadhdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.zip
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.gz
hdf5-c63ef2cba28df827eb090a019284c7cd8c2982af.tar.bz2
[svn-r11179] Purpose:
Feature: check-clean target Description: 'make check-clean' cleans up output files from tests. Solution: Tests create foo.chkexe and foo.log files. Scripts create foo.chksh and foo.logsh files. 'make check-clean' will clean these files up so that the tests can be re-run. Also suppressed some not-very-useful output of Makefiles when it would echo commands. Platforms tested: mir, sleipnir, modi4 Misc. update:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 1e4b883..31e1d7a 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -70,9 +70,9 @@ $(EXAMPLEDIR):
-$(top_srcdir)/bin/mkdirs $@
install-data-local:
- $(MAKE) $(AM_MAKEFLAGS) install-examples
+ @$(MAKE) $(AM_MAKEFLAGS) install-examples
uninstall-local:
- $(MAKE) $(AM_MAKEFLAGS) uninstall-examples
+ @$(MAKE) $(AM_MAKEFLAGS) uninstall-examples
# We want to install the source files, not the examples themselves. Add '.c' to
# each example to get its source. This is a bit kludgy.
@@ -89,9 +89,9 @@ uninstall-examples:
fi
check-install:
- $(MAKE) $(AM_MAKEFLAGS) installcheck
+ @$(MAKE) $(AM_MAKEFLAGS) installcheck
installcheck-local:
- $(MAKE) $(AM_MAKEFLAGS) check
+ @$(MAKE) $(AM_MAKEFLAGS) check
# List dependencies for each program. Normally, automake would take
# care of this for us, but if we tell automake about the programs it